cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Replica Vault

Highlighted

Replica Vault

So I am trying to set up a Replica Vault at a new location. I have the server at the new location completely set up and working.

I get the Host set up, the Vault Created, the Root Folder added, but I can't Mount it. Whenever I go to Mount the folder I get an error of:

"Create mount for root folder "brillionvaultfolder" failed. Nested exception is:wt.util.WTException: Mount status cannot be determined."

Can anybody help me out with this issue as I cannot find any information on it and have read all the help articles pertaining to this.

Windchill 10.0 M030

11 REPLIES 11

Re: Replica Vault

Hello,

Try that :

Security key: Was there any regeneration of the Security Key (Site - Utilities - File Server Administrator - Site Administration - master - Update Keys). If this had been done, then you would need to download the key from master and place it in the replica server as well and restart application in Replica.

Pascal

Re: Replica Vault

There hasn't been any Regen of the Security Keys. I have one Replica set up just fine but when trying to set up this one I get an error. Everything is set up just the same amongst the two Replica Vaults.

I tried the restart of the Replica and still no luck with getting the mount set up.

Re: Replica Vault

Are you sure the root folder had been Enabled and not Read Only?

Prabhakaran V.

Re: Replica Vault

I can't Enable it until I mount it to my understanding.

It is greyed out and says "Cannot be enabled; mounts missing"

Re: Replica Vault

In your File server Administration\Site administration, did you declare the new replica ? you won't be able to mount before.

Re: Replica Vault

Vaults.PNG

This is what my Site Administration page looks like... Is there something else I need to do? The Brillion_Replica is the one I can't get to work and the setup page is set exactly like the Beloit_Replica Site.

Re: Replica Vault

Seems ok.

Now, on the menu File server Administration \ File server management

File Servers list

i assume you also see your replica and it is not offline ?

FileServers.JPG

Re: Replica Vault

Vaults.PNG

It always says my sites are Locked and require restart... I have restarted the Replica Servers Multiple times and tried to unlock the Sites. Any insight as to why I would have this issue?

The Beloit Replica was set up by PTC consultants so I "Assume" it is done correctly...

Re: Replica Vault

Lock means your replica is on read only mode (no upload) but available for reading content for users.

The repository icon is not transparent, means the replica is active. So that's good.

The little triangle suggest you need to update replica definition from main server no ? i don't remember the meaning of that triangle but...yes i think that's it.

The update process is automatically managed by Windchill if the property wt.intersvrcom.autoManageCCS is set to True (default).

But you can force it by using the broadcast configuration in your vault menu, file\broadcast config

When the upgrade occurs the status will change to read only....that's your case i guess, and a message restart is needed appears plus a triangle.

Normally by stopping and restarting your services on the replica the triangle should disapear

and running a windchill version both side on main server and replica should show the same.

If you're in the mess update doesn't run properly ask ptc consultant or try to review the windchill install and config guide, page 193:

Updating an Existing Fiille Server IInsttallllattiion Manualllly

If your system is not set up to update existing File Server installations

automatically when the master site is updated with a maintenance release or patch,

you must manually update each File Server site:

1. Shut down all Windchill-related server applications, including the method

servers, web server, servlet engine, and server manager, and exit all Windchill

shells.

2. Open a system console and navigate to the

<Windchill>/bin/CCSTools

directory.

3. Using ANT, execute the script file

install_ccsdsu.xml as follows:

ant -f install_ccsdsu.xml

Note

If

ant -f install_ccsdsu.xml fails on the first attempt, run it again to

successfully complete the update process.

4. Move the contents of the directory

<Windchill>/codebase/

CCSTools/update

directory to the <Windchill>/codebase/

CCSTools/Completedupdate

directory, overwriting the files in the

destination folder.

5. Once the execution completes, start Windchill.