cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

new part from template copy associated drawing, common name mapping to PDMlink name ?

Newbie

new part from template copy associated drawing, common name mapping to PDMlink name ?

Looking for help getting this all to work properly ? see screen grabs in attached PDF


Basic situation


I've moved all of our template files into common space Library/proe standards/templates


example PART_TEMPLATE.PRT & PART_TEMPLATE.DRW


the drawing contains nothing more than the model "no format no view's"


I've updated the config.pro file to point to the correct folder!


when I create a new part using the PART_TEMPLATE.PRT & select copy associated drawing, mostly everything works... I get the new part and drawing in my workspace... the one thing I can not get is the common name value entered when creating the new part to map to the name field in PDMLink ?



also one weird thing I've noticed is no matter what I name the new part, the 1st time I save the file I get a message that the file already exist, do I want to overwrite it ? yes I have no otther choice...


anyone been through this tangled web of confusion, any insight into what I might be overlooking or doing wrong will be greatly appreciated.


We are running ProE wildfire 5.0 m050


PDMLink 9.1 m050


thanks


Dave


Dave McClinton


Sr. Mechanical Designer / MCAD System Admin


"RCP"


Richardson Cooling Packages, LLC


731 Moravia Street


New Castle, PA 16101


Phone: 724-698-1015


Fax: 724-652-4142


Email:dmccl@coolingpackages.com


Web:

1 REPLY 1
Highlighted

new part from template copy associated drawing, common name mapping to PDMlink name ?

Dave,

I use a relation in Pro/E to copy the value of the common name parameter
to the name parameter:

NAME=PTC_COMMON_NAME

Best regards
Jan


On Wed, 12 Oct 2011 23:42:10 +0200, Dave McClinton <->
wrote:

> Looking for help getting this all to work properly ? see screen grabs in
> attached PDF
> Basic situation
> I've moved all of our template files into common space Library/proe
> standards/templates
> example PART_TEMPLATE.PRT & PART_TEMPLATE.DRW
> the drawing contains nothing more than the model "no format no view's"
> I've updated the config.pro file to point to the correct folder!
> when I create a new part using the PART_TEMPLATE.PRT & select copy
> associated drawing, mostly everything works... I get the new part and
> drawing in my workspace... the one thing I can not get is the common
> name value entered when creating the new part to map to the name field
> in PDMLink ?
>
> also one weird thing I've noticed is no matter what I name the new part,
> the 1st time I save the file I get a message that the file already
> exist, do I want to overwrite it ? yes I have no otther choice...
> anyone been through this tangled web of confusion, any insight into what
> I might be overlooking or doing wrong will be greatly appreciated.
> We are running ProE wildfire 5.0 m050
>
> PDMLink 9.1 m050
> thanks
> Dave
>
> Dave McClinton
> Sr. Mechanical Designer / MCAD System Admin
>
> "RCP"
> Richardson Cooling Packages, LLC
> 731 Moravia Street
> New Castle, PA 16101