cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get an answer that solved your problem? Please mark it as an Accepted Solution so others with the same problem can find the answer easily. X

"No Cache designated vault" exception while uploading graphics

RichardSteadman
1-Newbie

"No Cache designated vault" exception while uploading graphics

Hi,

I'm using Windchill ProjectLInk 9.1, trying out the Structured Authoring test cases.

When trying to load a graphic file into the workspace "Tech_Pub", after selecting the file and
clicking finish, the UI goes to a page with a "Processing..." gif animation and never returns.

I checked the MethodServer log file (MethodServerLog4j-7344.log), and it has an exception:

2011-06-14 10:16:56,090 ERROR [RMI TCP Connection(26)-10.0.0.82] wt.fv.uploadtocache -
(wt.fv.uploadtocache.uploadtocacheResource/10) wt.util.WTException: There is no Cache designated vault or active folder for Cache designated vault on Local Master Site.

Does anyone know what this means and how to fix it?

Thanks,

Richard Steadman

1 ACCEPTED SOLUTION

Accepted Solutions

Richard, try this:

1. Go to Site>Utilities>External Storage Administrator>Vault Configuration.

2. Click each folder/vault/host in the right area, then click Mounts>Validate, confirm no error message.

Make sure there is no Read-only vaults/folders and all the vaults/folders are enabled

View solution in original post

10 REPLIES 10

Richard, try this:

1. Go to Site>Utilities>External Storage Administrator>Vault Configuration.

2. Click each folder/vault/host in the right area, then click Mounts>Validate, confirm no error message.

Make sure there is no Read-only vaults/folders and all the vaults/folders are enabled

Thanks for the quick reply Dmitry,

In the Hosts section, the defaultuploadfolder did not validate. So I unmounted it and made

a new one in a new folder on the file system, and then it did validate.

I was able to load the image into the workspace.

Thanks very much

dtsarev

please tell me where  i can find the Site>Utilities>External Storage Administrator>Vault Configuration. and  i am not the administor of the Croe ,and whether i  have the right to modify .

and  please tell me the detail

You need to be a site Administrator to access Site Tab. Could you get hold of an administrator or administrator credentials?

There is a least preferred method of updating the db tables, if you have db access.

Thank you,

Binesh Kumar

Barry Wehmiller

thank you , I  am not the Croe administer , I am just  a user.

I could able to Check-In few components, but trouble with some due to this error. How can I resolve?

Thanks in advance.

swood
6-Contributor
(To:DmitryTsarev)

I am having the same issue. I have now validated each mount, but it appears that EVERY folder is read only. I also can't see how to change that.

Am I seeing this correctly, and can you help?

Vault.PNG

BineshKumar1
12-Amethyst
(To:swood)

This looks good from a validation stand point. However you would need at least a folder to be writable, a - sign for the column  read only. You can double click on the kruger vault and uncheck the read only flag.

Thank you

Binesh Kumar

swood
6-Contributor
(To:BineshKumar1)

Thank you for the input. I have been out of the office, so I hadn't replied yet. We found out that the folders were being set to read only because the server was full. We removed unreferenced documents and that saved us 660 GB, so we're good to go.

In addition to the accepted solution you can also visit:

Top Tags