cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Want the oppurtunity to discuss enhancements to PTC products? Join a working group! X

Assemble parts as Inactive in Simp Rep

KE_2142943
4-Participant

Assemble parts as Inactive in Simp Rep

Is it possible to assemble parts in a simplified rep. as inactive? I'm creating an assembly that has thousands of parts and they all get assembled at default location. Right now I have to assemble each part and then after I've done a handful I go into the simp. rep. options and change them to inactive. I'd like to assemble each part as inactive so I can skip the extra step.

Anybody know if this is possible?

5 REPLIES 5
StephenW
23-Emerald II
(To:KE_2142943)

If your top level is set as "Master Rep", all the new components will be "included".

StephenWilliams_1-1627928928770.png

 

If your top level is set as "Exclude", all the new components will be "excluded".

StephenWilliams_0-1627928910169.png

 

KE_2142943
4-Participant
(To:StephenW)

Unfortunately that is not the case for me.

My top level assembly is set to EXCLUDE but when I insert a new assembly, it comes in as MASTER REP.

 

KE_2142943_1-1627929657007.png

 

 

KE_2142943_0-1627929627743.png

 

StephenW
23-Emerald II
(To:KE_2142943)

Notice it doesn't say "Derived".  Any time you are working in a specific rep and you assemble a component, that component will "initially" be set to Master Rep in the active rep regardless of how you set your top level. You have to Save the Active rep to keep the status, otherwise the component will switch back to the default (master or exclude)

However, all the other reps that are inactive, the new component will follow the top level setting (master or exclude, ie "derived"). 

I will typically will add components to a rep I want to see the component in. All the other reps will either show the component or not based on the top level setting (master or exclude). You have to Save the Active rep to keep the 

KE_2142943
4-Participant
(To:StephenW)

I appreciate all your help but unfortunately this still doesn't work for me. After assembling files into my EXCLUDE assy and saving the Simplified Rep. the files are still in MASTER REP state. Thanks for trying to help me resolve this.

StephenW
23-Emerald II
(To:KE_2142943)

When you save the rep you are working in, that tells Creo you want it to be kept as you have it. If you don't want those components in your current rep, simply don't save the rep.

Top Tags