Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Creo 6 crashes when opening/verifying family table - fatal error


Creo 6 crashes when opening/verifying family table - fatal error

I am using Creo Parametric - Release 6.0 (connected) Release 6.0 and Datecode6.0.6.0

First i don't know what is the "connected system" phrase and how to find it on my computer.
So the one i put is arbitrary choosen from the list...
If you know how to find mine, please tell me, thank you 🙂
Here is my problem :
I have a generic part which has 2 instances. Generic is OK.
Until some more geometry modifications, the 2 instances worked very well.
I was able to open them from the family table, and was also able to modify the functions etc ...
But now, each time I try to open one of these two instances from the family table window, Creo crashes with fatal error.
Same fatal error occurs when I try to verify the family table.
I tried by deleting theses instances. re-creating them, making them more "simple" to try again and trying to go step by step to see where is the problem but same fatal error occurs.
I also repaired the potential geometry errors displayed in the menu "Tools -> Verify geometry". But nothing changed. Still the fatal error.
Can you please help me ?
It is a important file for my company.

I can send the entire traceback.log file if it is needed.
Thank you for your support.

Exception EXCEPTION_ACCESS_VIOLATION has occurred in the thread 14244.

Here are the errors that I faced
The trace creation timestamp is: mar. juil. 26 17:52:05 22
The executable build timestamp is: jeu. févr. 04 09:03:18 21
The datecode is: 2020354
The pro machine type is: x86e_win64
The process ID is: 20964
The traceback type is : CRASH
The logger exit status is: 00003
Exception EXCEPTION_ACCESS_VIOLATION has occurred in the thread 14244.

Thread 14244
0x00007FF77E1DDE68 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x0, 0x0, 0xa8274278, 0x517b0d60 )
0x00007FF77E1DF338 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0xffffffff, 0xa8274278, 0x1, 0x57d8bd88 )
0x00007FF77E1DF10C NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x15, 0x5955b529, 0x1, 0xffffffff )
0x00007FF77E1D9E43 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x1, 0x2, 0x5955b628, 0x0 )
0x00007FF77E1D9B49 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x5955b620, 0x7e1e2354, 0x0, 0x4025e5c8 )
0x00007FF77E1D9B21 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x0, 0x57d8bd88, 0x2, 0x2 )
0x00007FF77E1DF4F8 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x497d7708, 0x1, 0xc15ee, 0x2 )
0x00007FF778DFCB2E NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x4025e5c8, 0x0, 0x0, 0x2 )
0x00007FF778E0CD7C NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x180e, 0x0, 0x554a8bd8, 0x4 )
0x00007FF778DF1BEA NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x4025e5c8, 0x5955bd70, 0x1, 0x0 )
0x00007FF778DF1A45 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x394, 0x5955bc09, 0x4025e5c8, 0x5955bd70 )
0x00007FF77AC6A5AF NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x5955bd70, 0x3e, 0x1, 0x78d5cd16 )
0x00007FF77A5FC17A NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x180e, 0xffffffff, 0x0, 0x78d5b299 )
0x00007FF77A5FC24D NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x8, 0x47f41e10, 0x567d0e50, 0x1000000 )
0x00007FF77A5FC27F NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x8, 0xffffffff, 0x47f41e10, 0x180e )
0x00007FF77A5FC2F9 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x180e, 0x552fe5e8, 0x8, 0xa4b5f )
0x00007FF778D60348 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x47f41e10, 0x180e, 0x459a4bc8, 0x18e2f8a0 )
0x00007FF779C5AEC1 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x0, 0x5, 0x79c57760, 0x57d8bde8 )
0x00007FF779C5CCA1 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x3bcec8b0, 0x3bcec8b0, 0x8, 0x5955bfb9 )
0x00007FF779C5EC68 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x1, 0x0, 0x1, 0x0 )
0x00007FF779177610 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x84, 0x0, 0x0, 0x0 )
0x00007FF779176F5F NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x47f41e10, 0x5955c320, 0x0, 0x4900b9d8 )
0x00007FF778D4C010 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0xffffffff, 0x0, 0x1, 0x5955c760 )
0x00007FF778D45ADC NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x0, 0x5955c7c8, 0x0, 0x47f41e10 )
0x00007FF778D3D946 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x0, 0x0, 0x0, 0xffffffff )
0x00007FF778D4D4F5 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x47f41e10, 0x1, 0xffffffff, 0x0 )
0x00007FF778D4D47A NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x1, 0x1, 0xffffffff, 0x1aa )
0x00007FF778F4FA99 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x0, 0x1, 0x5955c960, 0x1 )
0x00007FF778F4C598 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x0, 0x4, 0x5955e190, 0x0 )
0x00007FF778F4AAA0 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x18e2f8a0, 0x1, 0x5955e260, 0x18e2f8a0 )
0x00007FF778F4A4EF NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x477878d8, 0x0, 0x18e2f8a0, 0x2 )
0x00007FF77A1E9356 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x5955e6f0, 0x5955e6f0, 0x0, 0x0 )
0x00007FF7776D4847 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x2, 0x48faca50, 0x1, 0x2 )
0x00007FF7776CB3B2 NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x2, 0x5955f250, 0x0, 0x2 )
0x00007FF7776B5F1A NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x48faca50, 0x1edaf560, 0x48fad0b0, 0x1 )
0x00007FF7796ADCFA NULL (NULL:0) (xtop:0x00007FF776880000) ( 0x0, 0x3fc01648, 0x2a6847c0, 0x0 )
0x00007FFE341EB314 NULL (NULL:0) (coretools_sh:0x00007FFE341A0000) ( 0x0, 0x0, 0x0, 0x0 )
0x00007FFE333769A2 NULL (NULL:0) (baselibmt:0x00007FFE33280000) ( 0x34eb2f00, 0x0, 0x34b342f0, 0x0 )
0x00007FFE900F1BB2 NULL (NULL:0) (ucrtbase:0x00007FFE900D0000) ( 0x0, 0x0, 0x0, 0x0 )
0x00007FFE92767034 NULL (NULL:0) (KERNEL32:0x00007FFE92750000) ( 0x0, 0x0, 0x0, 0x0 )

Hi VladimirN,

Thank you for your answer.
I tried the two solutions :


1. add enable_opengl_fbo no to my file
2. add g:win32_gdi to my file

But unfortunately the error and crash is still here.
I do not have any problem to launch Creo 6 and work with.
A lot of others parts with family table work very well.

I have problem with only one part.
The instances of this part are really simple. It is only disabling of some functions, that are at the end of the construction tree of the part. With no child function.
When I tried to disable these function manually in the tree. It works.
But not trough the family table ...

Any other suggestion that I can try ?

thank you