cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Drawing layers

cpoirier
Regular Member

Drawing layers

I work for a very old company with files from 1998 to date with assembly models that have 17+ years of designers and drafters who put litle thought into layers. Is it possible to ignore model layers and status entirely and have only layers in my drawings that I assign. Some of my assemblies are 400+ parts. I use WF3.0, but will soon be changing over to Creo. I can make it work but as of late it has been a slug fest to get the results I want in the drawings.

 

Tags (1)
4 REPLIES 4

Re: Drawing layers

Yes and no. The model views respond only to model layers and can be set independently of the status of model (either on a full drawing or by-view basis), allowing those working on the model to set layer visibility as they like without changing which layers are visible in the views. Drawing entities are controlled by drawing-only layers.

 

Can you add more about the problem you see?

Re: Drawing layers

I have an assembly that has two fuel lines made using the pipe feature. (Creo 3.0m150/WC10.2)

I am attempting to make a layer with a rule to collect the pipe centerlines and make it easy to hide them in the assembly drawing. Theyu ;ayer is in the top level assembly. The rule will find the features in the rule editor, but once I hit OK it's a no go. If I go back to the rule editor it can no longer find the feature. The options are set to associative, rule enabled, and independant. What am I doing wrong?

 

 

 

 

 

Re: Drawing layers

Wrong file attached previously.

 

 

Re: Drawing layers

OK, well I made it work but the solution is not elegant. I tried manually adding layers with the pipe features in the parts, even when hiding those in the drawing they will not hide.

 

Solution: 

Make sure all the models involved are checked out including the drawing.

Open the top level assembly (do not use the model tree in the drawing, no way to save status) and select the pipe feature in the part and hide it. Save the status. Save the assy.

Open the drawing.

review>update drawing view>select view and OK

make sure to save status and then save.

 

I am guessing the old pipe feature is a gray area between solid geom an not as the centerline is part of the feature some how. Is this why the pipe CL will not load with a rule or hide by the layer?

I use the pipe tool all the time for hard lines. Glad I found a solution.

Talk about a real PITA to get what you want.

I never solved the layer rule issue.pipe cl fixed.JPG

 

 

Announcements