Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Want the oppurtunity to discuss enhancements to PTC products? Join a working group! X

Dual dimensioning using decimal inches and imperial fractions


Dual dimensioning using decimal inches and imperial fractions

Our vendor who uses a CNC machine to cut out our sheet metal parts needs our fabrication drawings to show decimal inches to create his CNC program. When we receive the finished parts back from our vendor, our shop verifies the bent sheet metal parts using tape measure which are imperial fractions. The parts aren't highly critical so we don't get into any problems using decimals and fractions.


Is there are way using dual dimensioning to show decimal inches as the primary dimension and fractions as the secondary dimension? I've tried several different configuration options and none have worked.


If there are no settings to do this, does anybody have a work around?


Thanks, Steve


I don't think there is any way to do what you want to do. The fractional/decimal setting for dimensions is a binary selection for how the numeric data in the dimension will be displayed, it is not a units designation.

I tried some "tricks" to see if I could achieve the effect you're looking for, but they failed:

(1) Defined a new unit, called "inchDecimal" thinking I could use that as the secondary dimension on the drawing, but this didn't work because apparently drawings only allow "official" unit designations.

(2) Tried to use "inch" as the secondary dimension units, thinking it might represent the secondary units in the default decimal representation, but it's too smart to fall for that and showed both as fractional numbers.

Other solutions would be, depending on the complexity of your models, lots of work:

(1) Put multiple dimensions on the drawing for the values you need to inspect, maybe having one view for decimal dims and one for fractional.

(2) If you want the two versions of the length shown in one dimension, you could create the two dimensions, make only one of them fractional. Add a reference to the "other" dimension in the one you want to show, using the "Dimension Text" functionality and adding a line that looks like "&ad8" to the second line of the dimension. Then "Erase" the "other" dimension.

If your drawings are complicated, the first option is probably how I'd go. I'm sure someone will mention that this is against the rules of ASME and/or ISO whatever and whatnot, but oh well.

A non-CAD solution we used to use for one of our sales folk was to make up a chart of the fractional equivalents of the decimal dimensions. Given you're using a tape-measure, the smallest units you'll likely have to deal with are 1/16th of an inch, so it wouldn't be too large of a chart...

Thank you. I was worried that Creo wouldn't allow two dimensions shown that aren't equal.

Sadly this has been requested long ago (nearly a decade.....) in the past, proposed as an idea to PTC, and the CREO Gods never saw fit to bless us with this functionality.


07-02-2013 POST -  Dual dimensioning - primary decimal inches, secondary fractional inches

25-Jul-2017 IDEA POST - Is it possible to have dual dimensions, both inch units, one showing decimal and one showing fraction in Creo Parametric 


Here is the work around i found:

  • Create the dimension in decimal -> "primary" dimension
  • Create the dimension AGAIN but in fractional display this time "secondary" dimension
  • Drag the secondary to format it nicely next to the primary dimension
  • Hide or otherwise smallen/shrinkify/erase the leader to the secondary dimension... sometimes creo won't actually do anything if you ask it "erase leader" so you have to just drag the leader tip towards the dimension until it dissapears itself (i.e. with ordinate dimensions)
  • Click your secondary dimension
  • Choose "dimension" tab
  • Choose "Dimension text" drop down
  • Put square brackets [ ] around the @D

Hopefully you'll get something like in the attached image.

the one downside to the workaround i mentioned, with ordinate dimensions, is if you intend to jog one of the dimensions. you can't hide the jogged dimension witness line by just dragging the resizing ball at the tip of the witness line towards the dimension to make it disappear... oh and "erase witness line", while an available option on ordinate dimension witness lines when right-mouse-button-clicking on it, does nothing.


Ordinate dimensions with dual dimensions Decimal [FRACTIONAL]

1. Setup your ordinate dimensions as normal. Make them look all nice



2. Repeat the same ordinate dimensions again based on the same zero (select the “.00” icon before you start ctrl+clicking the various locations again)



3. Ctrl+click or click and drag to select all your NEW dimensions together.



4. Go to the top bar “dimension text” and enter square brackets around the @D so it looks like [@D]



5. Go to the top bar “dimension format” and select the “Fractional” radio button



6. Now hover your mouse over one of the new “secondary” dimensions you have created until the double-arrow shows up, indicating you can reposition the dimension along the leader line. Reposition the dimension so it is reasonably close to be considered visually associated with the “primary” dimensions.



7. Now move the mouse to the bottom of one of the leaders until the leader-resizing blue ball shows up at the tip of the leader. Click and drag the leader resizing blue ball in the direction of the dimension until the leader tip is approximately where you want the start of your new “secondary” completely disappears






The one issue that I still have yet to resolve is the jogged dimensions. You can’t hide the leader for a jogged dimension. Hence why in the above image the “secondary” dimensions corresponding to the jogged “primary” dimensions are overlapping their neighbor. “hide witness lines” is useless here. Literally does nothing. If you right click a leader on an ordinate dimension and select “hide witness lines” it does nothing. Even though it is NOT grey out and IS fully selectable.


Top Tags