cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about the Community Ranking System, a fun gamification element of the PTC Community. X

How to Disable automatic regeneration in model

hshagle
5-Regular Member

How to Disable automatic regeneration in model

We are working on some large assemblies and taking more time for regeneration.

We have disabled auto_regen in config pro option(enable_auto_regen:NO).

but still all instance are getting regenerate while we are editing the single feature in generic.

please help me out on this.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Trebla
15-Moonstone
(To:hshagle)

Hi hshagle,

If you work with windchill, you could change all your objects of the work-space to read-only (except objects you are editing) and then use the config option:

 

regenerate_read_only_objects no

View solution in original post

3 REPLIES 3
Trebla
15-Moonstone
(To:hshagle)

Hi hshagle,

If you work with windchill, you could change all your objects of the work-space to read-only (except objects you are editing) and then use the config option:

 

regenerate_read_only_objects no

hshagle
5-Regular Member
(To:Trebla)

Hi Trebla,

Thank you for information.

Is there any other option available to disable an auto regeneration in part model, when we are working on particular features, instance are getting regenerate automatically when updated the feature in the generic model.

Trebla
15-Moonstone
(To:hshagle)

Hi Hshagle,

 

You could try 'set read-only features', I am not sure if this improves regeneration time...

 

Read Only Features.jpg

Top Tags