cancel
Showing results for 
Search instead for 
Did you mean: 
Security Alert Log4j Security Vulnerability. Click here to know more.
cancel
Showing results for 
Search instead for 
Did you mean: 

Invalid View for Showing BOM Balloons again

MarkRafn
1-Newbie

Invalid View for Showing BOM Balloons again

ok,ok -- I know this has been asked many times before, but for the life of me I can't find a summary of postings. Just single emails asking the same thing and no responses... (I will post a summary with all responses once the dust clears)

Using WF4 M050 -- I cannot add balloons to a view with a supposedly assigned repeat region. I get the Invalid View for BOM Balloons error. No matter what I've tried I can't get this to work. I understand ( I ~think~) how repeat regions are tied to models/reps. I have narrowed the problem down to trying to place 2 views.

Here's how I'm setup...

ASM1.ASM

REP1

REP2

REP2 also shows some parts in REP1

Create a drawing. Drop in View1 with REP1 on sheet 1. Create Table with Repeat Region and show balloons = ok. Drop View2 with REP2 on sheet 2. Create Table with Repeat Region -- note: table displays correctly with only parts from REP2 -- Show balloons and I get the Invalid View error. huh?

Further testing... So maybe it's the format/template? If I go to Table > BOM Balloons > Set Region and try to reset the REP2 region I get the error "There can only be one BOM balloon region in a view template". The drawing was created using a template, which had a view and table as part of the template. So--I created another drawing using no format and just Size. Did above view creation and presto, both views created ok with correct table each.

So is the problem my format? Or am I missing something?

thanks for your help and suggestions.

-mark


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
1 ACCEPTED SOLUTION

Accepted Solutions

Mark,

Make sure your repeat region is created by the same model that the view is created from if you have multiple models in an assembly. That is the only time I have seen this error.

Thanks,

Jason

View solution in original post

2 REPLIES 2

Mark,

Make sure your repeat region is created by the same model that the view is created from if you have multiple models in an assembly. That is the only time I have seen this error.

Thanks,

Jason

View solution in original post

msmith
14-Alexandrite
(To:jasonb13)

To determine the source model for views and repeat regions:

 

  • View
    • Layout tab > Select the view > Right Click > Summary for View > Note the value of Simplified Rep
    • msmith_1-1638814774077.png

       

  • Repeat Region
    • Table tab > Repeat Region button > Model / Rep > Select the region > Note the message area indicates which model and rep are used
    • msmith_2-1638814783748.png

       

Announcements