Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about the Community Ranking System, a fun gamification element of the PTC Community. X

Problem in selecting parts


Problem in selecting parts

I am facing problems to select a 3D part in an assembly, when I posisionate the mouse on the part it gets preselected, but when I click to select, it doesn't select the part. After trying twice, three times the part gets selected. It seems to be a configuration problem, because when I use the touchpad of my laptop, I can perfectly select the part, with no single problem. I already replaced my mouse to another one and the  problem is the same.


Can anyone helpe me with this situation?


I am using Creo 3.0 M080.

My laptop is a Dell, processor intel i7, RAM memory of 16GB, dedicated AMD video board of 2GB.





uninstall mouse driver software provided by Dell and test Creo.


Martin Hanák

Hi, I removed the mouse device at the control panel, and inserted it again. The problem continues.

But I think it´s not the mouse itself.

On Creo, when I go to File > Options > Selection and turn off the option to enable preselection highlighting, I can perfectly select the parts with just one click, but it's very hard to work on this way.

If anybody has another hint I appreciate. My OS is windows 10.



This may help - this is from the PTC Tips and Tricks document:

PTC Creo Parametric provide various filters, including the Individual Selection filter, Compound Selection filter and Smart filter, to help you select items. PTC Creo Parametric automatically selects the Smart filter, if it’s available. The Smart filter enables you to select the most common types of items that are valid for the current geometrical context. This filter works on two levels. As you begin the selection process, the Smart filter allows you to select general, higher-level items (e.g., features or components), and after you select the higher-level items the Smart filter automatically narrows the selection scope to allow you to select more specific items, such as edges or faces. This process allows you to spend less time changing filters and more time modeling.

The problem with using the Smart filter is that it can take several mouse clicks to select geometry when the filter is engaged. For example, to select an edge to round on a model with the Smart filter on, you’d first select the feature, choose the surface that contains the edge, and then select Edge—for a total of three clicks.


  You can reduce the number of mouse clicks from three to one if you temporarily disable the Smart filter. To do so, simply hold down the Alt key. Now you can select the Edge by mouse clicking directly on it. (This tip can be used in any version of PTC Creo Parametric.

Hi everyone, the problem keeps me bothering, I don´t know what to do.

I still have to click several times to select a part in an assembly, using a mouse. Using touchpad of my laptop is OK, I can select a part with just one single click.

I am pretty sure that is a system configuration problem, because I already exchange my mouse three times and the problem continues.

I hope somebody can help me.

Thans a lot.



the problem is related to your notebook, therefore it is difficult to help you.


What mice did you test ? I suggest you to test some cheap 2 button+wheel "animal".


Also read



Martin Hanák

Yes, I am almost sure that is just a system configuration problem. I can´t believe my touchpad works properly and my mice doesn´t.

I have tryed 2 mice Satellite - model A15 and 1 HP. The three are very simple with 2 button+wheel.

I don´t have problems with zoom.

Hi everyone, I found out how to fix this problem about selecting parts. I bought a new monitor to use with my notebook, this second monitor opens Creo and I can use it with no problem. I think the problem is the resolution of the screen on my notebook, because only on my new monitor Creo works well, at my notebook's screen it keeps not working properly.

Does anyone know how to fix the resolution on my notebook, or if the issue is not this, what is happening?

My new monitor is a Dell P2314H - 23" - 1920x1080 - 60Hz

The only other thing that comes to mind is the laptop screen is using different graphics hardware/different graphics mode. AMD has been the most complained about graphics hardware (the Intel one has been a close second.) No idea if it's the hardware or the driver and there are too many combinations of Creo, OS, driver, hardware, to maintain a decent list.




The problem is because, pointer precision is turned in mouse options.

If that is turned off , selection is good.

But, pointer precision is very useful on all other places, with that turned off , selection of icons and other stuff becomes harder , because pin pointing with our hands is hard .

I think, PTC developers have to do something about it. ( which i believe will not happen ).



I'm having the same issue in Creo 3.0 on a Windows 10 laptop. Out of curiosity, does your laptop have a high-resolution display, e.g. a 4K display? If so, what is your scaling factor set to in the Windows display properties?

My laptop has a native resolution of 3200x1800 pixels, so I need to run my scaling at 200% to keep things readable. Knowing how poorly Windows supports display scaling for these newer displays, I wouldn't be surprised if the selection issues in Creo are related to the either scaling factor, resolution, or just lack of 4K monitor support in Creo.

I too will be buying an external monitor one of these days, so I'm interested to see if this problem goes away. Your results keep me hopeful!

I have the same problem, laptop screen hard to select, if i move Croe to a 2nd screen its no problem, any solution would be welcome


We faced the same issue.There is some issue with high resolution monitors.This is fixed in Creo 3.0 M140 Date code.

We need to set 'high_dpi_enabled' to 'yes' in


Just wanted to update this thread. I've since purchased a separate monitor (with a standard 1920x1080 resolution) and the selection problem persists. I'm not even using the built-in laptop display anymore, so it's just like a desktop computer with one of the displays turned off.

What graphics card/chip are you using?

It's a GeForce GTX 970M, which admittedly isn't the best choice for an OpenGL application like Creo. My laptop also has an Intel HD 530 chipset for 2D graphics, so the switching might be causing the selection problem (I believe the internal graphics are still used to draw the application window). I'd like to try the Direct3D driver with Creo, but it crashes the software on launch.


we have the same issue for the last few years since we moved to 4k displays. it's a real problem is you use surfaces a lot. selecting them is a nightmare. and trying to select multiple surfaces to merge or cycle through surface to select.

so I have one external 4k and 1 external 1080 monitor to resolve the issue, but working on my laptop is near impossible.

All hardware are Dell Precisions with Quadra cards, tested on 7 different laptops (2 models including the very latest 15' precision) tested with Win7 Win 8 and Win 10 with various drivers. 

we do have a Precision desktop working quite successfully on dual 4k however


I've had the same issue for months and have tried everything in this forum and more.  I've finally found something that works!  It's not the mouse, NVidia settings or anything else in this string of posts.  I simply changed my display resolution from the max (1920 x 1080 on my laptop) to 1600 x 900 and suddenly it's like I'm working on myexternal monitor.  It makes no sense, just like any solution to a problem that itself makes no sense.  But it works, at least for me.


Thanks for the tip about the screen resolution reduction, it seemed to fix the part selection problem for me too :).


We faced the same issue.There is some issue with high resolution monitors.This is fixed in Creo 3.0 M140 Date code.

We need to set 'high_dpi_enabled' to 'yes' in



THANK YOU!  This resolved the very frustrating pick issue for me as well, and it vastly improved the appearance of Creo in general.


I just switched to a new machine and am running Creo 3.0 M150 on my dual monitors at 3840x2160, and was not as pleased as I had hoped with the higher resolution.  This 'high_dpi_enabled' option wasn't found through the configuration editor, so I edited my manually and upon restarting Creo - WOW!


Thank you again for sharing your solution.  It made my day!




What a silly thing to have turned off.


We have been struggling with this for weeks and it seems to have fixed it for us as well!


Thank you. 🙂

Same problem here. I'm running Creo 4.0 M060 and I'd say that about 20% of my clicks are missed. I also ran into this issue on Creo 3.0 M120, but it seems much more prevalent in the newer version. My system is about as basic as it gets: single monitor, 1920x1080 resolution, GeForce GTX 960 video card, and a generic mouse.


I tried to duplicate the problem and it seems to go away if I am very "deliberate" about selecting items, allowing my cursor to come to a complete and full stop prior to clicking. It almost seems like Creo has a built-in delay between when the button is clicked and when it registers the click. I tend to work quickly and I think my cursor is already off of the object by the time Creo logs the click. For those of you who said the issue went away when using a laptop touchpad, I wonder if it's simply because you have to slow down by nature of the input device, since it's not as fast as a mouse. We already know that Creo messes with the timing of clicks--a "quick" right-click will cycle between parts, whereas a "long" right-click will bring up the context menu. This is different than just about every other application, where a right-click of ANY duration will activate the context menu instantly upon button release.


As for the DPI scaling fixes that were posted, I think that's a separate issue entirely. High DPI support is a mess on Windows (see here) and porting over applications from the legacy GDI scaling system is extremely labor-intensive. I've seen situations where certain programs can't interpolate the higher pixel density, resulting in unresponsive interfaces. But, I don't think that's the root of the problem here--I believe it's with the way Creo times the registration of mouse clicks. Even a few milliseconds would make a huge difference if you're quickly moving the cursor across the screen and want to select something along the way.


I've opened a ticket with PTC to ask them about this, but I'm sure I'll get the usual "works to product specifications" non-answer when they don't feel like fixing a bug or improving the interface. I'd be interested to hear if anyone else could comment on my speculation above.

23-Emerald II

I helped a guy here with a brand new laptop (I think HP workstation). It was simply a windows scaling issue. It was not a 4k monitor/video card.
RMB on the desktop, display settings, change the "scale" to 100. The user went from extraordinarily frustrated to productive.
If you haven't tried, you really should.

Thanks for the tip. I'm already running at 100% scaling, though.


You can try enabling DPI setting on parametric.exe loacted under parametric\bin folder.Attached screenshot.Hope this helps.


Best Regards,


Having the same problem here, where it seems that Creo is forcing me to pause before clicking in order to select something on screen.

I was not able to fix this with any screen resolution changes.

However I did find something else that I didn't see mentioned in this thread that seems to have improved my situation:

Under "Additional mouse options" in windows 10 mouse settings, under the "Pointer Options" tab, I had a toggle box selected called "Enhance pointer precision".  Once I unchecked this box, my click success rate improved dramatically.  I think it is still not as perfect as I would like but it is definitely much improved.


I had same issue.

I fixed in this way


Right click - Display Settings - Advance scaling settings 

Turn off "Let Windows try to fix Apps so they're not blurry"

Change scaling to a custom (try first with 100%)




I noticed the problem when my laptop was disconnected from the docking station.

With docking station, no problems. Out, I had to click 6-7 times in order to select a surface, even if the selection filter was set on surface union.


I solved by going into resolution settings of the display (windows10), in the sheet "Scale and layout", and changing "Change the size of text, apps, and other items" value to 100% (it was 125% by default).


Everything turns a bit smaller but you will be able to work with ProE without frustration.


Hope it works for you too.



Top Tags