Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Query- Assembly-Merged Solid-Shrinkwrap


Query- Assembly-Merged Solid-Shrinkwrap

Hello PTC Community members,

Assembly Management


I have one large assembly & I am doing Shrinkwrap (Save as Shrinkwrap) of this total assembly.

When I follow the steps as below;

1. File--> Save As --> Shrinkwrap

2. Merged Solid -un-check fill holes

3. Clicked OK

then in message bar at down in creo, it is showing - 'Merging component' completed. (Find attached screenshot)

But at the last I am not getting Shrinkwarp file. I am getting error message as below

"xxxxx_sw0001" regeneration completed with atypical feature or component status. Failed: 1. Child of Failed: 1.
Could not create model xxxxx_SW0001. Aborting.

Assembly-Merged Solid-Shrinkwrap issue.jpg


How to search the exact part/feature in assembly because of which I am getting this error??

Thank you in advance.



Vinit Kadam


One place I would look for more information is the trail file.

The approach I would take is to suppress components until the Shrinkwrap worked.

Hello dschenken,

Thank you for your reply.

I opened respective 'trail.txt' file; this file contains around thousands of lines.

Please guide me how to find which part is creating issues in shrinkwrap process.


Find attached respective 'trail.txt' file. (ohh not able to attach trail.txt- getting error 'The contents of the attachment doesn't match its file type.')


Regarding 2nd approach, in my assembly there are total 83 parts (Feat# count - I mean parts & sub assemblies), so I feel this is time consuming approach to suppress components one by one. And find out the component which is causing issues in shrinkwrap process.



Vinit Kadam

Creating Shrinkwrap is quite cumbersome for assemblies many times and normally be a trial and error method.

I would first hide any surfaces, cosmetics, then check and fix any geometry checks, suppress any internal components that are not visible from outside, suppress any Text features or threads.

If there is any complex casting model, then sometimes matching the accuracy of that part and the assy will work.

Earlier this week I was having the same problem. Turns out the model was an import from solidworks and someone had modeled all the thread. Once I got rid of all the threads, the shrinkwrap worked.

There are potentially hundreds of reasons a shrinkwrap will fail to create. 

You can troubleshoot by suppressing 1/2 your assembly. try the shrinkwrap. If it works, the problem is likely in the 1/2 that you surpressed. (this may not be true as the problem can be with the intersection of 2 components)

You should be able to attach the trail.txt file if you remove the .xx iteration off the file name.

Someone should have taught you binary search.


Suppress half the components. If it works, then resume them and suppress half the remaining ones. If it still fails, suppress half the remaining ones. There should be no more than "n" suppressions for 2^n components; in other words, if there are 128 components, then 7 or less steps would be required.


The easiest way to deal with the trail file is to try the shrinkwrap and then exit Creo, so the error message is very near the end.


The file you attached is truncated and does not have thousands of lines.