cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Have a PTC product question you need answered fast? Chances are someone has asked it before. Learn about the community search. X

Search query using look for component: unexpected results returned in one test case

tbraxton
21-Topaz II

Search query using look for component: unexpected results returned in one test case

Refer to the posted video for details on this issue.

 

When searching for components in an assembly model I would expect both parts and subassemblies that satisfy the search criteria would be returned as found. I am not seeing this in a test case. In one query all parts and assemblies are returned as found. In the second query only parts are found. I am not understanding why these results are different. 

 

Can anyone explain why the two search queries shown in the video do not return the same results as found? The files needed to replicate the video are in the zip file (Creo 4 models).

 

========================================
Involute Development, LLC
Consulting Engineers
Specialists in Creo Parametric
1 ACCEPTED SOLUTION

Accepted Solutions
tbraxton
21-Topaz II
(To:tbraxton)

As I had suspected it was not working to spec; SPR 13218218. PTC has responded with a fix scheduled for Creo 7.0.8.0+. At this time older builds will not be corrected for this issue.

 

========================================
Involute Development, LLC
Consulting Engineers
Specialists in Creo Parametric

View solution in original post

3 REPLIES 3

pausob_0-1632432466329.png

Using "Solid Model" as the object works as expected?

I believe this was addressed by @MartinHanak in another post - seems that "component" and "solid model" are different animals in the Creo universe...  Though it is a mystery why your 2nd search query returns the two sub-components. 

 

find.png

 


Martin Hanák
tbraxton
21-Topaz II
(To:tbraxton)

As I had suspected it was not working to spec; SPR 13218218. PTC has responded with a fix scheduled for Creo 7.0.8.0+. At this time older builds will not be corrected for this issue.

 

========================================
Involute Development, LLC
Consulting Engineers
Specialists in Creo Parametric
Top Tags