cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Tolerance Display Changes in .drw

SOLVED
jjohnson-4
2-Guest

Tolerance Display Changes in .drw

Hi,

I am using Creo 2.0 M130. When I open a drawing with diminsions or create a new drawing and add diminsions, I cannot change the Tolerance mode in the dimensions properties dialog box. It is greyed out and cannot be changed. However, by searching the web, I found that i could change it for a particular drawing if I go to File -> Prepare -> Drawing Properties, I can click on Detail options -> change, find tol_display and change it to *yes* and then close. Now, just on that drawing, I can modify the tolerance mode of each dimension. So I do have a work around but it is on a file by file basis.

When I check my config.pro file, I do have a parameter tol_display and it is set to yes. But this does not seem to resolve the issue.

Any help or suggestions are greatly apprciated.


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
1 ACCEPTED SOLUTION

Accepted Solutions

Jon,

Set drawing option tol_display as yes.

File > Prepare > Drawing properties > Change Deatil options > Tol_display as yes

You can add this option in template drawing.

View solution in original post

6 REPLIES 6

tol_display.png

Jon,

Set drawing option tol_display as yes.

File > Prepare > Drawing properties > Change Deatil options > Tol_display as yes

You can add this option in template drawing.

View solution in original post

Hi Mahesh, while this is correct, it does not solve my long term issue of applying this as the default for all drawings. I have a .frm file that i use that includes my title block, etc. When i try to add this parameter to this file it does not appear or let me add it.

Jon,

If you are starting your new drawings using a drawing template (not format), then you need to change the tol_display option in that template (all your templates if you have multiples).

If you start your drawings and just add your format, you need to find your drawing setup file (usually specified in your config.pro) and edit that file to your desired tol_display option. The drawing setup file will have an extension of .dtl

This will only affect new drawings created after you fix this option. All drawings already started will have whatever setting was in affect in that drawing was created. Your option to fix this is to manually correct it as you Mahesh showed above or reload your corrected drawing setup file (be careful with this one as it may updated other stuff).

You simply can't globally fix all the older drawings created since the drawing setup file is loaded at the time of drawing creation.

Steve


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)

Stephen,

Thanks, your answer was very helpful and makes sense. I had found some discrepancies on new vs. older drawings and now I know why.

Hi John,

The folloowing link may be of help to you. https://www.youtube.com/watch?v=B2O9pb-Y_ys

Hope you find it useful.

Announcements