Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Help us improve the PTC Community by taking this short Community Survey! X

Optimization study issue


Optimization study issue

Hi all,

If I star an optimization study, the log reports that Creo2 is being started in the background.

The command shell opens, xstop is listed in the active processes, bu then nothing happens.

The model is really simple, resources are not a problem, but Creo does not seem to update the features selected for the optimization.

Any idea?


5-Regular Member

Does the log report that Simulate is trying to recover from an invalid parameter update?

You can create a Sensitvity Study, with the same variables and bounds as the optimization, and Shape Animate the model. If the model updates successfully while stepping through the different Shape Animate values, then there is a much better chance that the model will update successfully when it is running an Optimization study

I opened a case over 1 month ago with PTC regarding this same issue where the run appears to start but never completes. So far, I haven't recieved an answer from PTC. Sorry for the bad news. I have a call into PTC today to inquire on the status. Once I find out something, I'll let you know.


Last Friday I also experienced this issue. Same thing. Simple model with some forces, some shell elements and some simple displacement constraints. The standard static structural analysis ran beautifully. But when I tried to run either a sensitivity or design optimization study, both got stuck in this endless loop trying to open up "Creo in the Background". I've also seen several other users have this issue but have not had an answer just yet.

I have issued a case, talked to them on the phone for about a half-hour and then eventually uploaded the part file with the simulation definitions. They said they would have to get back to me. Not very hopeful they'll have a solution.

You guys have any ideas?


Exact same problem happening to me today. Ran many modal optimizations yesterday without problems. Can't have anything running today.


Well PTC couldn't recreate the issue after uploading my model to them.Of course they suggested updating to the latest datecode which currently is M120 (M130 is available after 4/21/17).

After upgrading to the latest datecode I do not have this issue anymore. Perhaps they have patched it?

I am having this issue on Creo This is the latest datecode for Creo 5.


Hope you still check your PTC community account... Did you ever resolve this?


Seems to me that the optimization study just doesn't work and PTC doesn't want to admit it, in order to get you to buy the topology optimization extension...

this issue crops up once in a while. in my experience the problem is generally not a model problem but a computer or installation issue that might be fixed with a fresh install. Creo needs to launch in the background to regenerate the model and sometimes it doesn’t correctly launch. all sorts of things might cause this from system paths, to launch configuration files to lack of available Cad licenses and probably other things i don’t know about. i generally remove all creo versions and reinstall fresh if the problem persists. i always add the parametric/bin path to my system path so i can launch ptcstatus by command line anywhere. oh also when it launches in the background your config file will not be loaded and it could possibly attempt to use a folder you do not have read write access to for instance for trail files. if you only have read access to program files/PTC/ and sub. try changing this to R/W and apply to all subdirectories.

anyway there’s my thoughts and attack methods on this issue. this has popped up a few times over my 23years using creo and i have always got it back working without too much trouble.

Would you mind explaining how to add Parametric/bin to my system path? I'm not sure what you mean here.


Also, how do I change to R/W? I have admin. rights on my PC so I should be able to do that, I just don't know how. I'm a relatively new Creo user <1 year.

These are general computer management items, not Creo.  Here are some links I found.

You might want to do some more searching to understand paths and file permissions.



Permission change.PNG





I've added this stuff but still have the issue.

Did you try uninstalling all CREO programs and reinstalling?

I just uninstalled everything and reinstalled Creo 5040. Still getting the same issue.

Can you send the model?  I have

I can, but I can't figure out how to upload the file here. It has a .prt.1 extension which is apparently invalid for this forum.


Try downloading it from this google drive link:


I was able to resolve the issue though opening a case with PTC.


Turns out, optimization studies only work if your simulation "output file location" is your working directory. I use a separate folder on my hard drive specifically for FEA. Seems that optimization studies don't like that.


I changed the output file to match my working directory and it worked. Thank you for helping me with this!

No problem.  Thanks for posting the solution about the output directory!  Be sure to mark your own response about the output directory as the answer.

Top Tags