cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Found: Several "operating system command" characters!

naglists
1-Newbie

Found: Several "operating system command" characters!

Save this for your next bout of insomnia ...


Made an interesting discovery upgrading from Arbortext m010 to m090. We
found occurrences of the following Unicode character U+009D in our files. I
am setting up a hunt and destroy mission so I do not have exhaustive
information but it appears that they show up in our mainframe screen
captures. I suspect the characters have been there all along but that
previous versions of Editor and Publishing Engine have gracefully (to me,
perhaps buggily to Unicodologists) ignored them.

We discovered them through FOSI formatting errors reporting characters that
were unavailable in Courier New and that they were being replaced with
Arial MS Unicode. (No matter, formatting-wise, they have no output impact.)
PE complains about something-or-other(157) and yes, the way to create this
character, in Editor, is to type alt-0157 using the number pad. Or, in my
case fn-alt-0157 using the in-laptop-keyboard-fn-number pad. If you know
what I mean.

By creating an instance of this character, I could copy it to the
Find/Replace dialog and replace all occurrences with null. Problem solved.

When you encounter this character in text, it is invisible. You can watch
your cursor do weird things if you navigate across one or more of them (and
they did seem to appear in small multiples) but otherwise, you can't see
them there, in Editor, any more than you could see them in the PDF.

Hmmm. Just realized, I never tried looking for them in a PDF. Probably
won't. Don't care.

While typing this up, I realized it is possible that the fonts installed on
our m010 and m090 PE servers were not necessarily identical. (I don't know
for sure. I don't care. Won't be checking.)

To be clear, it is this guy:
1 REPLY 1

I get it all the time for the 8206 control character (left-to-right [LRM]).
Certainly nothing I am putting in the XML. 😄



Lynn


Announcements