cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

.ism IsoDraw Macro File File Format

GregoryMackenzi
1-Newbie

.ism IsoDraw Macro File File Format

Hi,

Offhand does anyone know what the actual text "format" the IsoDraw Macros are in? ANSI, DOS, UTF-8?

I find that if I edit the .ism files with Textpad they can no longer be read by IsoDraw afterward. I'm forced to edit them in Notepad which is not really ideal.

Greg

1 ACCEPTED SOLUTION

Accepted Solutions

Appears they are Unicode.

Not perfect, but if you use Notepad to open and then do a Save As it'll show you in the lowerleft the encoding it's in (not detailed by any means, but good enough in most cases).

I don't use Textpad but I assume it's similar to jedit. Likely in the the settings you can set default encodings it will recognize. I ran into this on a project in which it opened the files and modified the encoding without notification. Should be a pretty straight fix however.

View solution in original post

2 REPLIES 2

Appears they are Unicode.

Not perfect, but if you use Notepad to open and then do a Save As it'll show you in the lowerleft the encoding it's in (not detailed by any means, but good enough in most cases).

I don't use Textpad but I assume it's similar to jedit. Likely in the the settings you can set default encodings it will recognize. I ran into this on a project in which it opened the files and modified the encoding without notification. Should be a pretty straight fix however.

Hi Trevor,

I'm on Windows 7, the default notepad accessory I have doesn't show that it is unicode but you are spot on. Textpad is somewhat similar to Jedit.

I set up the document encoding as UTF-8 in Textpad, also there is a second setting to save out as Unicode and UTF-8 that I had to set, and that solved the issue.

Thanks!

Greg

🙂

Announcements