Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Problem Starting Up Direct Modeling Express 4.0


Problem Starting Up Direct Modeling Express 4.0

Hi, does anyone have any idea what is going on with my downloaded version of CREO Elements/Direct Modeling Express 4.0? I have used it problem-free for several months on my Dell Inspiron 15R Windows 7 64-bit but just a day or so ago it started producing the following error message in a Window's message box;

Microsoft Visual C++ Runtime Library

Program: C:\Program Files\PTC\Creo El...

This application has requested the Runtime to terminate it in an unusual way.

Please contact the application's support team for more information.

The window provides an OK button which is the only choice. Clicking on the button causes Creo Elements/DME 4.0 to close down. I have no idea what is causing this. I have tried uninstalling and re-installing several times in combination with using Windows System Tools such as cleaning up the registry, etc. but it still produces this error message.

I would appreciate it if anyone had any idea what is causing this problem and how to fix it.



This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.

can not remember / find anything identical

the issue is that it worked before and stopped working form one day to the other. Such unexpected changes mostly occur when

+ a new driver was installed - e.g for the gfx graphiccard and which causes trouble now

+ windows installer did install something which did have an influence. (low confidence in this cause)

+ something happend which did "set user customization incorrectly"

So you need to check if there is anything written in the event log file when starting - may this helps you to identify the source.

Or to find and view the windows error reports (if there are) May they help to detect the cause.

I got a runtime error when I tried to start Direct Modeling Express 4.0 after unpluging the AC adaptor on my notebook computer. It seems that when the AC adapator is unplugged, the notebook turns from a high power graphics processor to a lower power graphics processor. When I replugged in the AC adaptor and launched DIrect Modeler Express 4.0, it started flawlessly. You might look into a similar cause/event for your situation.

Stephen, Try right clicking on your desktop. Look for configurable graphic processors. Select the high performance one.

if that solves your problem, you can go into power settings in Control Panel find advanced power settings. Find the section on graphic processors. Select the high performance processor both plugged in and unplugged.