Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

asyncoremt.dll file is missing


asyncoremt.dll file is missing


I have the all programms of creo 2.0 student edition installed on my pc. There wasn´t any problem at all.

After I had done this, I tried du run Creo Parametric, but it didn´t work.

I systemfail appeard:

"The programm can not be started. The asyncoremt.dll file is missing on the computer.

Install the programm new, to solve the problem.p"

I copied the licencse in the source @ setup, by moving it with my mouse.

I hope you can help me, thank you


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.

Did you ever find a resolution to this? I had never seen this before today either but one of our users bumped into it.

The file should be located in similar place to D:\ptc\Creo2Parametric_M010\Creo 2.0\Common Files\M010\x86e_win64\lib

If you found out what root cause was i'd be interested to hear, for us the problem no longer repeats and the file was there.

One of two things can cause this kind of problem... not having ownership of the Creo install folder and not having the location in your path statement. It is a similar problem as making Purge work. Take ownership of your Creo install folder. If that doesn't solve it, add the ...lib folder to the path statement.

Hi All

I have also come across this issue (asyncoremt.dll missing). In fact its quite common in my environment where i would say 75% of the machines ive installed in on give this error. (I install it on a range of school computers)

Most times I am able to change permissions and remove the Read Only access on the PTC folder. This seems to fix it however I have come across one that I cannot get to work.

No matter what I do it still continues to tell me that asyncoremt.dll is missing at start up. (A quick search of the directory shows me that the file is not missing.

The computer has windows 7 home edition and no matter what changes I make to folders permissions, they have reset themselves back to what they were originally as soon as I click on folder properties again.

I have uninstalled and reinstall half a dozen times still with not luck.

Even worse, now when I install it, and I double click to run Creo Parametric, Layout, Thermal, Direct or Structure. Nothing at all happens.

Any help or ideas would be extremely appreciated.

Thanks in advanced.

You can always move the file to the windows folder where all the other .DLL files reside. It will probably throw up a second error with a different file... do the same again.

Thanks for the promt reply.

For some unknown reason on the 7th try at installing it this time it worked fine, not throwing the missing asyncoremt.dll error.

Strange?...But its working!

Glad it worked out in the end. Have a great day!

Attention: Creo 7.0 Customers
Please consider upgrading
End of Life announcement here.

NEW Creo+ Topics:
PTC Control Center
Creo+ Portal
Real-time Collaboration