cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Helical Entry in Creo 4

razmosis
10-Marble

Helical Entry in Creo 4

Has anyone ran into difficulty with creating a Helical Entry to a Mill Volume with Volume Rouging in Creo 4.0 M030?

 

Matt

1 ACCEPTED SOLUTION

Accepted Solutions
SteveLucas
13-Aquamarine
(To:razmosis)

matt,

just click the add button and type it in the box for option name = enable_classic_nc_steps and in the option value type yes then hit ok. don't try and use the find because it won't find it.

might have to close out of creo and restart to get it t to work.

Hope that works for you.

View solution in original post

18 REPLIES 18
SteveLucas
13-Aquamarine
(To:razmosis)

Matt,

Seems to be working for me. What is your issue with the helical entry? need more details to help you.

I have a mill volume that is 2.250" deep x 3.250" w x 4.375" l.  It is being finished by a 500 x .03CR end mill.

 

Scan Type is Spiral

Rough Option is Pocketing

Ramp Angle is 2

Max step Depth is .125

Step over is .175

Helical Diameter is .125

Lead Radius is .125

Over travel is .125

 

The cutter profiles as I'd expect it to, but does not helical into the bottom slice as I am use to seeing.  It just plunges after profiling and cuts the bottom of the pocket.

 

Thank you,

Matt

 

SteveLucas
13-Aquamarine
(To:razmosis)

Matt,

I don't think helical option works with the pocketing parameter. I usually do 2 sequences to finish a pocket because of that. The first sequence finishes the floor with parameters set to the same as yours except the rough option is set to either rough or faces only with a wall stock of the amount of stock you have on the wall or maybe a bit more stock so the cutter doesn't touch the wall. The second finishes the wall with parameters set to follow_hard_walls and profile_only  with lead in and lead out and cutter compensation on to finish the pocket wall.

I have never cared for the pocketing option because if I have  to drift  or have spring passes to get the pocket to size it wants to recut the floor also.

We use pocketing quite often, and it should helical at the bottom.  It would in Creo 2.  What I am seeing here is that even if I set the parameter to Rough only, the helicals are not performed.  I see a few more parameters are listed now, but I haven't found one of them that affects the Helical motion.

SteveLucas
13-Aquamarine
(To:razmosis)

Just did a quick pocket with your parameters and it works for me ?

parameters.pngparameters1.png

OK, I see that you have Cut Entry Ext to Helix.  I typically set this for lead_in.  I changed that and I do get the Helix on the bottom.  However, I lose all the lead ins on the profiling portion of the sequence.

SteveLucas
13-Aquamarine
(To:razmosis)

Correct....That is why I don't care for pocketing and use 2 sequences to finish pockets you have a little more control over your pocket size with the 2 sequences. I think they need to add another set of entry parameters for pocketing sequence.

Well if this is in fact the way it is in Creo 4, it won't sit well here.  We use Pocketing a lot, and there will be several jobs that won't work right if reposted in 4.  We don't put Cutter comp into the majority of our programs.  Creating 2 sequences (3 with the initial rough) to finish a pocket just isn't going to be received well by our company.  I don't see why it would have changed.  I will have to search out a few more older programs and see if they work or not.

 

Thank you for your help.

Matt

SteveLucas
13-Aquamarine
(To:razmosis)

Matt,

there is a config option ENABLE_CLASSIC_NC STEPS that puts another setoff menus with classic mill volume in it. I haven't tried it but that might have the older style of pocket options for you.

config options.png

Steve,

 

I do not see that listed in my options.  How do you find that?

 

Thank you,

Matt

SteveLucas
13-Aquamarine
(To:razmosis)

I think it might be a hidden option where you have to type it in and it will run. As I was typing this I decided to try it before I sent it and the pocketing does work the way you expect with the classic option.

I opened a project created in Creo 2 with Creo 2 and verified that Pocketing works as I expect it to.  Saved the parameter file to ensure that I had exactly the parameters used on the project.  Then I opened the same project in Creo 4.  The path looks the same as it did in Creo 2.  Lead Ins on the walls, Helical into the bottom.  Then I created a new sequence of Volume Roughing.  Put the same Tool in, used the parameter file saved from Creo 2.  I then have to populate the Max Step Depth because that is new.  Play Path and guess what, no Helical at the bottom.  I can get the Helical, but at the cost of the lead-ins.

 

I copied the path in Process Manager, and the copy works fine.  I also tried copying the parameters from the previous step which works fine, but that does not work.

 

How do I find the hidden Config options?

 

Thank you

MattCapture.PNG

SteveLucas
13-Aquamarine
(To:razmosis)

matt,

just click the add button and type it in the box for option name = enable_classic_nc_steps and in the option value type yes then hit ok. don't try and use the find because it won't find it.

might have to close out of creo and restart to get it t to work.

Hope that works for you.

Steve,

 

I gave it a shot, but the OK button remains grayed out.  What am I missing?

 

Thanks,

Matt

SteveLucas
13-Aquamarine
(To:razmosis)

Matt,

I am not sure I don't have a computer here that doesn't have that config option running so I can't tell you what is the problem. I am pretty sure that is all I had to do to get the classic steps running. there might be other threads in here on how to get the classic steps set up which is where I got it from so maybe do a search for that? sorry not much help but once you get that set everything should be good for you

Thanks Steve! I found another topic on it and got it added.  It does work as long as the pocketing sequence is created in the classic menu.  I certainly am not thrilled about this change and the extra set of boxes on the ribbon, but at least it works and I know how to add hidden options now.

 

Matt

 

SteveLucas
13-Aquamarine
(To:razmosis)

matt,

I did a search also and found you have to add it manually. I am Happy you got it to work. I don't understand why they would take away functionality that was in a previous version. Maybe you should do a tech support call to see if they would fix it in 4.0 or maybe in 5.0

I logged a Case, it is #13981941.

Announcements