cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Post Processor Fails.....?

Highlighted
Visitor

Post Processor Fails.....?

Every time I try to post I get a "post processor fails" message. I was getting it last night but it went away after resetting my machine. Well its back tonight. I have tried other programs that I know work and have even tried on a different machine and it fails on everything. Has anyone else had issues with this?

15 REPLIES 15
Highlighted

Re: Post Processor Fails.....?

Judd,

I just started getting this error about 15 minutes ago.  I was posting all day long without any problems, in the same MFG assembly.  I rotated my coordinate system to match the latest part on the mill table and all I get is "Post process fails."

It almost happened from one minute to the next.  I posted one sequence and when I went to post the next one, the error came up.

I've rebooted all of the computers on the network that run ProE, I've tried recreating the cutting sequence (both inside the current MFG model and a brand new one), and I've tried to post known good programs from past parts.  Nothing works.  I don't think it's a coincidence that you're having the exact same problem within minutes of me having it...

I wonder if something got pushed to the computers (Windows Update, Java, etc.) that is causing the problem...

Highlighted

Re: Post Processor Fails.....?

Well isn't that interesting. Good to know its not just me. Guess we'll have to go to PTC to get this one figured out.

Highlighted

Re: Post Processor Fails.....?

Try emptying out your old TRAIL files.  My trail folder had over 1,000 files it, at almost 2 GB.  I emptied it out and the post process works again.

Check the config.pro option trail_dir for the directory location.  If you haven't set it and can't find it, search for trail.txt on you C drive.

If this works for you, it's one hell of a coincidence...

Highlighted

Re: Post Processor Fails.....?

So I had actually done that already and it still wasn't working. I resaved my CL file and now its working......WTF! Seems to be that if there gets to be to many trail files it messes up the CL file. Guess we'll have to pay more attention to that now. Thanks for you help. Glad your a late nighter like me.

Highlighted

Re: Post Processor Fails.....?

There is also a document CS26390 regarding this error.  Unfortunately, I'm not on maintenance, so I can't see the cause/resolution.  Any chance you are on maintenance?

https://support.ptc.com/apps/solution_preview/solution/lang/presolution?lang=en&n=CS26390

Highlighted

Re: Post Processor Fails.....?

CS26390.JPG

Highlighted

Re: Post Processor Fails.....?

What's funny is I had no idea I was on maintenance. I just tried loggin in. HA! Guess you know where to go if you need something from there.

Highlighted

Re: Post Processor Fails.....?

Here is the screen shot for the CS210340 document.

CS210340.JPG

Highlighted

Re: Post Processor Fails.....?

These kinds of troubles are why I set up a directory on my machine that I only use for writing .ncl files and for post-processing them into G-code. A simple short path (C:\ptc\NCFiles). I tell Creo where it is using the following entry in my config.pro:

pro_mf_cl_dir C:\ptc\NCFiles

My reason differed from yours; people in my company have gotten in the habit of using ridiculously long directory names in an already complicated directory structure. There is a limit to the length of the directory name that the post-processor can handle (from SPR, 242 characters) which, amazingly, these guys were exceeding.

Highlighted

Re: Post Processor Fails.....?

So this is one thing that I don't quite understand about this. This is refering to the length of the directory name being the cause. But is wasn't the length of a name that was causing the error. It was the amount of trail files. I didn't rename anything. I only deleted the trail files and it fixed it. Maybe you can clarify that for me.

Highlighted

Re: Post Processor Fails.....?

‌I keep my directory and file names short too...I learned my lesson back on version 20...

This error seemingly came out of nowhere for me. I posted a sequence, which was successful. Literally, less than 30 seconds later, I posted the next sequence in the operation and the error came up. I changed nothing.

Clearing the trail files worked instantly and they are in D:/PTC_Trail, or something to that effect.

Highlighted

Re: Post Processor Fails.....?

WTF!!!! Only one trail file and it just did it again. Had to do a full machine restart to get it working again but trail files are apparently not the problem. Setting up a pro_mf_cl_dir now. Hopefully that fixes it.

Highlighted

Re: Post Processor Fails.....?

Hello Judd,

I don't want to cry wolf, but is it possible that your hard disk is getting to the age where it starts doing funny things before eventually croaking?

Looks as if writing to the folder is sometimes generating the problem (judging by the message, most likely the system no longer or temporarily sees the contents of the folder).

Otherwise - considering you AND Chris had the same issue at the same time - maybe an update of a virus software is generating such an effect. It could block access in some way on purpose.

Gunter

Highlighted

Re: Post Processor Fails.....?

Gunter,

I agree that it could be an an update of something else.  The odd thing is that it literally happened from one minute to the next for me.  I successfully posted one sequence and when I posted the next one 30 seconds later, the error appeared.  Although, that could be an update running in the background.

FYI I'm running 5.0 release M080...if Judd is running something else, then it may have nothing to do with version.

Chris

Highlighted

Re: Post Processor Fails.....?

I hope my drive isn't going out. My whole machine is only 2 years old and all of our work is done on servers. We have to keep our Gpost and everything with startup on our machines but everything else including most of our pro and mfg config files are on our servers. The odd thing though is of the other 3 guys here no one else has had this problem. We have a computer setup with creo for employees who want to start learning it and one day when I was having this problem I went and posted out on that machine. But the next day even that one gave me the error. I haven't had the issue since the 4th so hopefully its gone.


I'm running 2.0 M120. And I think most of the other guys I'm with who haven't had it are still on 2.0 M80.

Announcements