Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Mathcad 3D plots do not work with Windows 7 64 bit


Mathcad 3D plots do not work with Windows 7 64 bit

When I try to run 3D plots with Windows 7 64 bit, it says "Failed to Launch Server Application."

Has anyone else had this problem? Is PTC trying to fix the problem?

Bill Edelstein
Baltimore, MD



Did you just install to your Win 7 64 bit computer? What version of Mathcad are you running? There is another post on this site, by a user who had the same error message, and uninstalled/reinstalled Mathcad and the 3D plots worked. You could also try running repair before uninstalling and reinstalling.

Some other suggestions:

1. Check “Enable 10-bit pixel format support” in ATI Graphics card Catalyst Control Center Settings.

2. If you can open the 3D plot dialog. uncheck show borders.

3. Try video card/driver-related adjustments--such as updating the video driver and/or turning down (or off) the Hardware Acceleration.

4. Register Mathcad glr.dll manually by following the below procedure: A. Run Command prompt as administrator. Type cmd in Start > Search > RMB on command and Run as administrator. B. Browse to the mathcad installation folder. C. Type regsvr32 glr.dll and hit enter D. Following message would be displayed “DllRegisterServer in glr.dll succeeded”.

5. Reduce color from true color (32 bit) to high color (16 bit).

Write back if none of these suggestions work.


This has been posted before

I know if your problem is all black 3D graphics a previous post had details on how to set a registry key to force the card to render

I have MathCad 14 and for Sony VAIO Windows 7 Ultimate 64 bit. Uses an ATI Radeon card. It worked for me. Still a bit dodgy when you scroll from page to page as it flickers all-black to graphics but at least I now see them and they print OK.

Setting I think was set using Regedit. But I cannot remember exactly what I did. The posted instructions were good. It was a year ago so you should really check the post before messing with the registry.
3-D Plot
ForceSoftwareRendering REG_DWORD 0x00000001 (1)


Just Change your MS office from 64bit to 32bitversion ( mathCad 15 is a 32bit application)