Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get called away in the middle of writing a post? Don't worry you can find your unfinished post later in the Drafts section of your profile page. X

Creo 3.0 - Licence request failed for feature


Creo 3.0 - Licence request failed for feature


I've installed creo 3.0 using a student licence. When I start Creo, a warning message (screenshot attached below) prevents the progam from running. Licence does not support this version. Is there an older version available for student download?

Thanks in advance.


After downloading and reinstalling v2.0 and everyting works fine. I've been using wildfire 5.0 so Creo looks and feels more fluid. Thanks.



Glad to hear it! So you are all set?

I am trying to install creo3.0 and I am having the same problem as mr. cramlet. I used the code BK400407EDSTUDENTUNICL for the simple license error. I don't understand what exactly mr. cramlet did to solve his problem, but I can't get it to work. I really want to start practicing with creo, but I can't get the license to work


Hi Joanthan,

It is likely that you have both the Creo 2.0 and Creo 3.0 licenses running at the same time. Please try reinstalling Creo 3.0 but on the licensing step, make sure that all existing licenses have been removed from the License Summary box (see below).


Once license summary is empty, then type in the product code into simple license entry and click install licensing. After that just follow the directions and you should be all set!

Let me know if you're still experiencing issues.

hello sir,

I am having a problem with the installation of student version of creo 3.0.I am not getting any cursor over the box where I am supposed to enter the student license.Please help me out.creoerror.jpg

pls anybody give the answer of this question as above.

reply on email ; -

I am having the same problem i have reinstalled it and yet again same message error.

You need use the trail instalation in the zip folder, I did it, and I don't have any problem

Try a new account, It worked for me

i have solved this problem: let's go try agaia.

there are a lot of setup in "MED-100WIN-CD-400_M070_Win64". we should run "setup-schools.axe" . if you run "setup.axe" you will have a problem. that's all.

if you still have a problem and question, you can contact me :


Hello Isaac,

I am a PTC certified CREO trainer and working since 2008 with PTC Channel partner.

This is the global problem i guess.

I am from India and here the students licenses are working in CREO 2.0 only. So till date the students product key is only supporting CREO 2.0. I dont know when does will it be in effect for CREO 3.0.

So better dont waste your time to install student license for CREO 3.0 it will not work.

The reason is very clear. As per the image you have attached contains detail of version which is 33.0. and this stands for CREO 2.0. For CREO 3.0 version should be 34.0.

So, the conclusion is there is no availability of CREO 3.0 Student license till date.

No, it's working in Creo 3.0 . ı had same problem but ı have just solved this problem. ı guess everyone ran setup.axe but you should have run setup-schools.axe . ı have solved by doing so



ok mr.

  Re: Creo 3.0 - Licence request failed for feature

   hakan aktas Copper


but , what is the licence code for this:  "schools" !!!


I have also the same trouble with the PTC Creo 3.0 version. After reading this thread, I have uninstalled Creo and reinstalled the "setup-school.exe" file. But, it does not work.

"License request failed for feature".

What can I do to get this programme running?


sorry, i dont know what you should do for solving. ı did like that i said then problem was solved.

First start up "setup" application; select "reconfigure existing software"; remove all but one license source by selecting the minus button. Finish by letting installation assistant reconfig. TA_DA!

Top Tags