Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Visit the PTCooler (the community lounge) to get to know your fellow community members and check out some of Dale's Friday Humor posts! X

Creo Elements/Pro Student stopped at 2% during installation. Problem?


Creo Elements/Pro Student stopped at 2% during installation. Problem?

Bought a copy of the student edition of Creo Elements/Pro Student Edition yesterday and cannot get past 2%. I have emailed - and had no reply. Is there a link to the full dvd rip?

I needed this up and running yesterday and am already wasting another day trying to get it to work. Please help.


I've had the exact same problem, and so far nothing has worked for me. I've wasted 2 days trying all of the things they suggest and nothing has worked for me.

The latest thing I'm trying with not much faith is downloading the full DVD image of the Schools Edition at this link:

I doubt it will help me with my Student's edition, but I'll give it a try. It's a huge 3.6Gb file.

I have already missed 2 assignments from my class with this problem.

I bought my downloadable student version as well on 12/01 through digitalRiver and have since then never advanced over 2%. I was able to download over the posted link the school version within 2 hours but it doesnt accept the student licence which I purchased. I didnt find yet a link to download the DVD image. Did you resolve the problem in the meantime?

If you purchased a Student Edition, the DVD media for this edition can be downloaded at

You do not want the Schools Edition as your Product Code will not work with it.

Because of the size of the DVD (3.7GB), I would suggest you use a download manager such as It will enable you to start, stop and restart your download if you need to.




Thank you Adam! I was able to download the file within 2 hours and to install it successfully on my computer.


I have had the same issue with installation but used the link that you provided and have now successfully installed Creo. But I purchased the elearning library bundle and I cannot access it.

How do I install the elearning library?

The elearning library isn't something you install. It allows you access to online course content when you login into the Presion LMS website. Here is the link:

I tried uploading this ZIP file and I got about 2.2 GBs of it when it said it was complete. When I tried to extract it said it was invalid. I see a lot of these post are several months old and yet when I tried installing the web version yesterday I had the same issue alot of the users were having a year (or so) ago. PTC has been no help at all. I sent emails yesterday (14 hours ago) and have yet to receive a response.

Disappointing to say the least. I'm about give up and pursue a refund.

Hello Sir am varathan from chennai. I had downloaded the creo/Pro student Edition 5.o in my lap. But i didnt get my product code. so that i couldn generate my license file. Please help me to get the product code sir. my mail id is -

We have also received your request at our - email address and we are processing your request.



Im having a bit of a problem with the student edition too it won't install keeps asing me for proxy server when i start the install? how do I get around this ?

We are aware of the proxy error, it will be fixed as soon as possible.

Until then, please email to - the fallowing information:

- product code

- HOSTID (MAC address of your network card)



-----Original Message-----
From: jamboe123 <>
To: student <->; ptc.nam <>
Sent: Fri, Aug 26, 2011 3:05 am
Subject: Fwd: having problems with installation of Pro-E


I am still having problems with this. I ordered it and tried to install the downloads and everything went fine until the last screen where it hung up saying 1%. I thought it was due to the size of the files so I letit run all night (12 hrs) and it still said 1% this morning. I have also tried downloading the whold DVD image and it won't even start up when i select "setup". It may help if I got the actual DVD but I can't order that now evidently. I have gotten no response on this so far. Can someone help on this?


-----Original Message-----
From: jamboe123 <>
To: student <->
Sent: Thu, Aug 25, 2011 8:53 am
Subject: Fwd: having problems with installation of Pro-E


I just bought the personal use version of PRO-E. My order number is below. I have downloaded the files. I have tried all day to get it installed. I get all the way to the last screen (including downloading the liscence, etc) which reads "PTC Installation Progress".

Download progress 100%.

Copy Files 1%.

At this point it stalls and goes no further.

Can you help on this?


-----Original Message-----
From: ptc.nam <>
To: jamboe123 <>
Sent: Wed, Aug 24, 2011 1:48 pm
Subject: Parametric Technology Corporation - Order Confirmation (Order #9271119726)

Dear Chris,

Thank you for ordering from Parametric Technology Corporation on August 24,

2011. The following email is a summary of your order. Please use this as your

proof of purchase. If you paid by credit card, please look for DRI*PTC on

your credit card billing statement.

Note: If your order contains download products, you can complete the download by looking up your order using the information and link below. When the order

summary appears, click on the Download link next to the product name. If your

order contains physical products, you will receive a separate email notification when your products have shipped.

To look up your order, please visit:


Parametric Technology Corporation Customer Service

Your Order and Billing Information:

Order Number: 9271119726

Order Date: August 24, 2011

Product SKU: ENG-4057C-L

Product Name: Creo Elements/Pro 5.0 Student Edition - Personal Use

Qty Ordered: 1

Amount: $240.00


Product Name: Extended Download Service

Qty Ordered: 1

Amount: $19.99

Shipment Tracking Numbers:

Subtotal: $259.99

Shipping: $0.00

Tax: $0.00

Total: $259.99

Discount: $59.99

Creo Elements/Pro 5.0 Student Edition - Personal Use - <p><b>Thank you for your order of Creo Elements/Pro 5.0 Student Edition- Personal Use

I have the exact same problem. I bought the product Dec 23, and now I can't install it

Per the post above, I hope it will be fixed as soon as possible, considering PTC has been aware of the problem now since at least 6 days ago....

You're better off downloading the CD image if possible. This has been a problem for at least 5 months that I'm aware of. The reply has always been its downloading a large CAB file and that's why it takes so long or antivirus or firewall or internet connection. For me that just doesn't make sense since downloading the CD image took less than 2 hours and downloading the 200MB web installer took less than 4 minutes for me. I don't know how packets translates into downloading data but when downloading the CD image there was a lot of internet activity and a large number of packets were transfered. After 4 hours initializing the install using the web installer there is almost no internet activity and the number of packets downloaded was about 2000. When downloading the 200MB installer file approximately 145632 packets were transfered in 4 minutes. Disabling antivirus and firewall made no difference. I've tried this several times and on different computers and always have the same problem. However, this seems to fall on deaf ears since they have tested it and it appears they have minimal or no problems.

Apologies for the problems you are having.

Here is a link to download the DVD image for Student Edition of Creo Element/Pro.




I'm having problems downloading the creo elements pro schools edition.

I registerd at the site, and no problem there, olso got the download link.

but when i try too download it stops almost immediately.

i tried different browser, and no difference.

i'm using a windows 7home premium 64 bit OS.

can anyone help me.


You can temporary disable your firewall or antivirus software. If this doens't work, please check with your internet provider or network administrator to remove any restrictions on your internet connection.

I know it's been mentioned before but firewall and antivirus are not the problem from my experiences. The download worked back at the beginning of November I believe (this was when I noticed a change). Electronic downloads seemed to stop working around the time the site design changed. The downloads only appear to affect the download of a ~3GB cab file from what I've heard from the education program employees. There is some download activity but it's extremely slow. After waiting four hours for the download of the cab file it only downloaded about 200 KB of data. The things that don't make sense to me is:

What changed to make something that did work at one time no longer work? Nothing changed on my end. One day the download worked the next it didn't.

Why can I download the 400 MB installer in 7 min?

Why can I download the ~3GB CD image in an hour and a half but can't download the ~3GB cab file? At the rate the download was happening for me it would take days to download.

I get the same results whether firewall and antivirus are activated or not.



I was thinking the same as you based on the subject of this post. However, I looked closer and I think Vali has it right. The problem posted seems to be simply that the DVD image could not be downloaded.

If the problem is that the installation (rather than download) stopped at 2%, then yes, the DVD should be downloaded and used.




That could be because I was basing it off what was in the title now that I look at it closer. Could be a timeout?

But as far as electronic downloads it still doesn't make sense to me why some things download with no problems but others do. Is there a restriction that could be placed on downloading a cab file? It was mentioned in other posts that the reason the installation was stopping at 2% was because it's downloading a cab file that's ~3GB. My reason for asking is because it affects other downloads. You may already be aware this but it affects electronic downloads for other versions such as WF4 Student Edition, it affects the training editions, and it also affects the CD image that is sent if a person requests it during the download process from the store because it contains only the installer file (based on what I've gotten in the past). It makes one wonder what is going on as electronic downloads have been a problem (at least for me) for 5 months or more and it has all been related to the installation. Which comes to my next question: Why continue to offer the selection of electronic downloads (at least for student versions) if there is a problem? Maybe it's already been addresses but the last time I purchased an electronic download (it has been a while) it linked to the installer not a CD image.

I have downloaded the DVD image and all of the items have installed but Pro Engineer Student Edition.exe does not execute. It looks like it kills itself in less than a second of opening. I have tried running it as an administrator and that does not change the behaviour of the program. I can open product viewer. I uninstalled and reinstalle and it has not rectified the situation.


This sounds like one of two things:

  1. Your graphics driver is not updated. You can test this as follows:
    • Use a text editor (Notepad or Wordpad) to open the file found at C:\Program Files\ProENGINEER Student Edition\text.
    • Add a new line of text to top of this file; "graphics win32_gdi".
    • Save the file, note that with Win 7, permissions typically have to be relaxed to let this save happen.
    • Restart Creo.
    • If it starts now, the problem is with the graphics card or driver. Typically this can be fixed by updating your graphics driver.
    • Note, you'll want to remove the line of text after you have the graphics updated. Creo will perform much better without this option set as it bypasses the graphics card.
  2. Possibly because you had already started an installation that never completed, a file could be locked or corrupt. Delete the "C:\Program Files\ProENGINEER Student Edition" folder and then reinstall.

I'm really sorry for your inconvenience. If these fixes don't work, please email - to request assistance.



Having a 1% - 2% install problem with Creo Elements/Pro 5.0 Student Edition on Windows 10. Tried disabling firewall, antivirus/internet protection software and Windows Defender, still no go. Sits a 1~2% for almost a day without change. Has there been any progress since 2010 on this type of install issue? Last time I had this type of installation problem was back in the Windows 3 era (Shudder!)



if you want to get some help, please provide exact information about steps you did.

Martin Hanák

Background Info
1. PC has 3 SSD's (first one is Windows 10, the other 2 are Linux) and 3 internal HD (data storage)
2. MBR is on the Windows 10 SSD.

3. Trying to install Wildfire 5.0 on Windows 10 SSD

Installation attempts
1. First several install tries using"default" values. Couldn't connect to to obtain license
2. Received license by email from PTC, but install locked up at 1%-2%. Noted that PTC Host ID was wrongly identified (license file had correct ID) but no way to change it
3. Restarted computer to see if BIOS settings were off but did not need to change.
4. Tried install again. Correct PTC Host ID identified but same stall point (1% or 2%)
5. Closed other running apps and deleted all PTC software and install files (including MathCAD), but same install result.
6. Stopped all antivirus and internet security software. Stopped Windows Defender and firewalls, but same result.
Several install attempts were run for a 8+ hours but no joy.
Could unplug (uninstall physically) all hard drives except Windows 10 SSD but way too much trouble to refigure the PC, so that's not an option.
Found out today from PTC that Wildfire 5.0 is no longer supported (retirement?) and to use Creo 4 instead. Unfortunately already spent $150 buying Wildfire 5.0.
Thanks for your help



1.) Note: I am not sure if it is possible to install ProE Wildfire 5.0 on Windows 10. ProE Wildfire 5.0 is not supported on this operating system.


2.) Do you use full installation DVD (3.5 GB) for installation -OR- do you use web installer (couple of MBytes) ?


Martin Hanák

I used Electronic Software Delivery from Academic Superstore.This was a zipped file containing 


1. x86e_win64_installer.exe

2. i486_nt_installer.exe


The installer files referenced above are each approximately 195 MB in size. I presume more files need to be downloaded from PTC via internet since the install DVD you mention is 3.5 GB.

Can I download the DVD image and use the license file that PTC already sent me?


I used the former file as my Wildfire 5.0 installer. Is this supposed to download other files from the PTC web site? When I tried to use for UserID and PTC password during the install, the installer kept telling me that it couldn't access the internet (asked for a proxy address). Message did not appear when I referenced the license file that was emailed to me.


Installer didn't squawk about Windows 10 when I tried to install Wildfire (not sure if that is any indicator of anything).



so ... now it is clear that you use web installer. It downloads other files from the PTC web site during installation. In case of communication problems it locks up ... this is normal behavior.


Possible solution no.1:

Move your computer to different place to different internet connection.


Possible solution no.2:

Email request to provide ProE WF5 full installation DVD to
enter this request on


Martin Hanák

Additional note:


If you have the functional software on another computer, then you can copy the installation directory to a new computer.



Martin Hanák