Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about the Community Ranking System, a fun gamification element of the PTC Community. X

Creo won't run!!!


Creo won't run!!!

Hi there!

When I attempt to open the program up, it fails to run b/c it states that it could not run the Quality Agent and if I call tech support to report an error 6. I thought tech support was open 24 hours but no joy on that. Any ideas, or should I just try in the morning? Thank you!!


I tried this Adam and it has no effect. Still the same problem.

Found a solution (that worked for me)!

I installed creo schools edition yesterday and had the same problem (quality agent could not be registered...).

Tried everything mentioned here in this thread, but no solution so far.

Then I remembered, that I disabled the quality agent during installation (last step before installation process begins).

Started setup again, but the option was't there anymore.


- Uninstall everything that has PTC in its name using control panel.

- Install creo again, do NOT uncheck Quality Agent in the last dialog window before installation

- Start creo...

hope that works for you as well.

I also had that error, 6 or 8 depending on different things I tried. After reading these posts I found a possible cause and a simple(?) solution.

I'm running Win7 and

Creo was installed by default in the folder Program Files.

Quality agent was by default installed in the folder Program Files (x86).

I uninstalled Quality Agent and then reinstalled it ( from C:\Program Files\PTC\Creo 1.0\Common Files\M030\install\addon) in the folder Program Files (same as Creo installation) and now it works fine.

Good luck to anyone with the same problem!


Thank you Christian for the workaround.

BTW......we will be releasing Creo 2.0 Student Edition (formerly the free Schools Edition) in a weeks time. Once available you will be able to register for it from Both releases can be installed on the same machine.



That worked for me. Thanks you very mucn !

Hi folks,

I installed Creo 2.0 Schools Edition and get an error regarding the qualityagent. After the error message Creo shuts down (dead end). I have done all steps in the blog: no success. I send you my error log.

Protokollname: Application

Quelle: Application Error

Datum: 20.07.2012 18:54:12

Ereignis-ID: 1000


Ebene: Fehler


Benutzer: Nicht zutreffend

Computer: Nextengine-PC


Name der fehlerhaften Anwendung: creoagent.exe, Version: 30.0.2012.130, Zeitstempel: 0x4fbc3c2e

Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 6.1.7601.17651, Zeitstempel: 0x4e211319

Ausnahmecode: 0xe0434f4d

Fehleroffset: 0x0000b9bc

ID des fehlerhaften Prozesses: 0x%9

Startzeit der fehlerhaften Anwendung: 0x%10

Pfad der fehlerhaften Anwendung: %11

Pfad des fehlerhaften Moduls: %12

Berichtskennung: %13


<Event xmlns="">


<Provider Name="Application Error" />

<EventID Qualifiers="0">1000</EventID>




<TimeCreated SystemTime="2012-07-20T16:54:12.000000000Z" />




<Security />













I am looking for an answer to start CREO 2.0. Thanks for your support.

Andreas from Berlin (Germany)


Have you tried opening permissions and reinstalling the Quality Agent as suggested above?

There is an issue with Quality Agent where if Creo is not installed by the same user who run Creo for the first time Quality Agent will not install because of a permissions issue.

If the software was installed using another user name, try running Creo using that user name. You may have to reinstall it as admin with that same user running it for the first time.

** Just be sure to save the license before removing Creo.




there is only one user and only one account. I have installed & reinstalled in all orders. I have givenacces to the folders by using everyone has all rights. Therefore I have no clue whats going on. I will not reinstall windows 7 to ust to get CREO 2.0 running. I am pleading for help.


I am also having the same problem. I have tried absolutely everything suggested above, I've reinstalled it seven times! I have Windows 7 and two program files, one for 64 bit and one regular and that seems to be the problem because I tried installing it on my friends computer that is 5 years older than mine and it worked perfectly. On my computer everytime I x out of the"welcome to creo 2.0" window, the window doesnt dissapear, and when i try to start a part, no planes or anything show up. Sometimes it tells me the quality agent is missing, sometimes it doesnt. Is there going to be a fix for this?

Hi Rachel,

Can I connect to your machine and take a look?

Please send me an email at - to invetigate.



Dear Mr Fischer

I have the same problem as the others. I've lost my whole day trying all the solutions given in here and they all resulted in failure. Same error for at least 30 tries (uninstall, install, repair, delete, enable agent , unable agent, firewall and antivirus on and off...). And I didn't actually saw a straight-forward solution from the PTC team which I do not admire. I have Creo 2.0 Student edition, licensed as I am an university student.
I will be delighted if a member from the team can connect to my computer and at least give a try to fix the problem.
Here is my email - -
I really believe you can sort this out and I am waiting to hear from you at your earliest convenience.

Markian Petkov

For Academic support, please see the PTC Academic Support forum. If you are unable to find a solution to your issue there, please submit an Academic Support Request. The support forum is monitored and maintained by the academic team and thus will provide more up to date solutions to your problems.

While this thread contains some useful information, much of it is outdated. As you can see the issue started in Feb of 2012 and Creo 1.0. Fixes were implemented for those issues at the time. More recently, there have been a small number of issues related to graphics driver updates from NVidia. Most of these have been fixed with the release of the M070 build code for Creo 2.0 however, a few remain. This morning I was working with development on a solution to those.

I would suggest that anyone having problem with the Quality Agent should submit an Academic Support Request so that someone from the team can assist you.

I have similar issue. I cannto fix it by any of your ideas. Please, help, I need Creo for my Univeristy project. I am using Windows 8 (but I have not any compatibility issue with other programs so I do not think it is Win8 issue), my laptop has Dual-Core 2.1 GHz processor and 4 GB RAM, also graphics ATI Mobility Radeon HD 4570. I did not found any Windows Alerts in its history. I add a screen capture while Creo crashes. Please help!


I found a solution - run CREO in administrator mode. To do that, you go into your start menu, go to the program, right click, and select 'run as administrator.'


am hvng the same problem. It just says the same error about Quality Agent, Please Reply asap b/c am headed for practicals now. Please do connect to my PC if needed. I tried all the ways that u have mentioned above.

Am usng

PTC Creo 2.0 Student Edition

Windows 7 UltimateError.png

submit your host id to get your license emailed to you. this problem occurs when we get our license online after entering our login id and password.

my host id is 18-03-73-56-D7-2D

my mail is -

kindly send soon..and also tel me the steps to be followed

Thanks in advanz..

my apologies....i did not write correctly.

you don't have to give the host id to me.

have you done training from and ATC in india if yes then you would have a "ptcgsindia"login id and password.

you have to submit your host id there.

please ask if you have ne more questions.

I encountered the same issue with error 9. The solution was to right-click open creo parametric "as an administrator," since it seemed the problem was that creo lacked the clearance to register the quality agent when it loaded. - worked for me, I am a happy CAD now.

Good luck!

I am writing with reference to the above thread, I am also facing the same problem. Latest instal date for me was around a month ago, but after all of a sudden it stopped working with following error which I will add it to the string now. Since my college project has been started I need the solution to resolve this issue. PTC admins please do the needful. I tried all the preferred solution posted in this form but nevertheless the result is same with error I attached below.


Hope to find solution soon


Purushottam Kanchi

Please submit a support request at Someone from the team will try to help you.

In general, it appears you Quality Agent is not installed or being blocked by your firewall or anti-virus.

I had this problem a few months back, managed to get a quick fix - it's not ideal, and doesn't solve whatever is causing the error message, but it overrides whatever bit of your computer hates quality control.

Right click the icon for Creo, and instead of clicking Open or Run or whatever the top option is, choose Run as Administrator.

I can't guarantee this will work for everyone, but it did for me, and as long as I do that, Creo runs without a hitch.


I had a similar problem with Quality Agent. Adam, Tim and Dimitri were helpful in trying to solve the problem.

Firstly make sure you are installing the software as administrator and running it for the first time.

In my case when installing Creo I had unchecked the Quality Agent box thus blocking its installation. It seems that Creo will only run with Quality Agent installed and permited internet access.

I fixed it by uninstalling Creo fully from my computer and the carried out a fresh install, ensuring Quality Agent WAS selected for insallation and PERMITED through the internet fire walls in order for it to comunicate with, I assume, PTC. [Autodesk software has a similar arrangement]

Since doing this Creo has run without any problem until the annual license expired.

When renewing the license the license update option did not take correctly and produced the error and closure situation. Again resolved with a uninstallation/fresh installation and again all is great!

Hope this advice is of help

Yeah I'm still struggling through this... I gave up on it several months back and have just used Creo at my internship between classes. Now I need to buckle down and spend more time in it, but still can't get the darn thing to run. Drives me nuts how much time you waste trying to figure this stuff out.



I found a solution that fixed it for me. I've been on many forms and nothing worked, and it seemed like most of the forms did not actually provide a solution or were unanswered. It seems like many people were having the same problem over different versions and builds of Creo, over the last few years. I got Creo 2.0 M130 to work on my Windows 10 computer. I was getting the error message "Creo Parametric is shutting down because it could not run the Quality Agent, which is required in this edition. If you call Technical Support about this problem, report error 0x0000000b." I've also gotten variations of this error message before, usually with a different error code.

The only thing that fixed it for me was allowing "Creo 2.0 from PTC" through the windows firewall. Here's how I did it:

1. Close out of all PTC applications.

2. Type "Windows Firewall" into the windows start menu, or open Windows Firewall through the control panel.

3. Click "Allow an app or feature through Windows Firewall" on the left-hand side


4. Click "Change settings", and scroll down and check the box next to the name "Creo 2.0 from PTC".

5. Also make sure to check the appropriate box on the right side of the line to allow access to private and/or public networks.


6. Hit Okay, and attempt to start Creo Parametric.

This worked for me, I hope it works for you.

Top Tags