cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Bug or wrong settings?

SOLVED
GABRIELSAS
Newbie

Bug or wrong settings?

Hi,

I'm not an experinced user and I've spent already several ours trying to identify the problem. Randomly it happens that some variables are not recognized. See the print screen. I'm suspecting 1) settings/preferences are not correct or 2) mathcad 15 has a bug. I reinstalled it, cleaned the registries. Not a solution. I attached the file also. I would apreciate your help.

Best regards,

GS

Capture.PNG

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Bug or wrong settings?

I'm suspecting 1) settings/preferences are not correct or 2) mathcad 15 has a bug.

Neither of the two. Look at the error message. Its telling you that there is a unit mismatch. If you evaluate L.m after its definition you would see that its value is 0.4341 (unitless!) and so Mathcad refuses to subtract it from TP which has dimension length.

You defined m:=0.1 earlier as slope and when you define L.m:=4.341m, m is not meter but 0.1. If you have the warnings turned on you would see the (re)definition of m underlined with that wavy green line.

Workarounds:

1) use a different variable name for the slope like "m.up" or, and thats tricky, you may name it "m." which looks like a normal m if the expression doesn't have the focus.

2) Assign either the slope m or (easier, as you only have to do it once) the meter m in the definition of L.m a different math style (normally both would be "variable"

I would vote for "m.up".

BTW, do you real find it convenient to put all your calculations in one text region? Its quite unusual and I guess its much less flexible and harder to edit.

View solution in original post

2 REPLIES 2

Re: Bug or wrong settings?

I'm suspecting 1) settings/preferences are not correct or 2) mathcad 15 has a bug.

Neither of the two. Look at the error message. Its telling you that there is a unit mismatch. If you evaluate L.m after its definition you would see that its value is 0.4341 (unitless!) and so Mathcad refuses to subtract it from TP which has dimension length.

You defined m:=0.1 earlier as slope and when you define L.m:=4.341m, m is not meter but 0.1. If you have the warnings turned on you would see the (re)definition of m underlined with that wavy green line.

Workarounds:

1) use a different variable name for the slope like "m.up" or, and thats tricky, you may name it "m." which looks like a normal m if the expression doesn't have the focus.

2) Assign either the slope m or (easier, as you only have to do it once) the meter m in the definition of L.m a different math style (normally both would be "variable"

I would vote for "m.up".

BTW, do you real find it convenient to put all your calculations in one text region? Its quite unusual and I guess its much less flexible and harder to edit.

View solution in original post

Re: Bug or wrong settings?

Much appreciated Werner.

Thank you.

Gabriel Sas

Announcements