cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Datum planes in a hidden layer will not hide in the model!

SOLVED
Newbie

Datum planes in a hidden layer will not hide in the model!

Okay, this is driving me crazy.

I have a part, and I've made datum planes on various surfaces of the part so that they show up in the drawing. I do NOT want them to show up in the model. I have added them to a layer and hidden the layer but the planes still wont disappear in the model. If I hide the planes directly in the model tree by using right click, the datums disappear in the drawing.

Please help me fix this problem! I've had mutliple people look at it and I'm about to give up and "fake" datums in the drawing instead of having them in the model. Like I said - they are in a layer that has been hidden but they wont go away!

I appreciate the help!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Datum planes in a hidden layer will not hide in the model!

Yes, the property of adding a datum tag as you show.

I just confirmed this is still a "problem" in Creo 2.0. Or at least it is very unpredictable. It seems to act differently when using Annotation to control display then using Hide/Unhide. I still haven't found the logic. I think in Creo 1.0, it is even more unpredictable. Also be careful, in Creo 1.0, I had many hard crashes when moving the datum symbol around. Save often!

View solution in original post

Tags (1)
21 REPLIES 21

Re: Datum planes in a hidden layer will not hide in the model!

You probably have datum symbols applied to them. I have had this problem and find this absolutely annoying. I've quit using, or even try using the ASME Y14.41 method of annotation.

If you remove the symbol attribute from the plane, it will probably act normally again.

Just for the sake of completeness, what version are you using?

Re: Datum planes in a hidden layer will not hide in the model!

I'm using Creo Parametric 1.0.

By symbol, do you mean the display option or something else?

Capture.PNG

Re: Datum planes in a hidden layer will not hide in the model!

Yes, the property of adding a datum tag as you show.

I just confirmed this is still a "problem" in Creo 2.0. Or at least it is very unpredictable. It seems to act differently when using Annotation to control display then using Hide/Unhide. I still haven't found the logic. I think in Creo 1.0, it is even more unpredictable. Also be careful, in Creo 1.0, I had many hard crashes when moving the datum symbol around. Save often!

View solution in original post

Tags (1)

Re: Datum planes in a hidden layer will not hide in the model!

After playing with this for a while, I might suggest a different way to define the GD&T datums.

In the video, Datum A was created using one of the primary datums and it would not behave as expected.

However, if you create these datum symbols as Annotations, the corresponding datum planes and axes will be displayed based on the properties of the annotation. Therefore, you can create the datums based on geometry and the system handles the associated datum planes which apparently shouldn't be used for anything else anyway.

Hope this helps.

Video Link : 3956

Re: Datum planes in a hidden layer will not hide in the model!

This is great, thank you! I like your way much better. One more question... my datum lines appears dashed in the drawing for some reason. Any idea how to fix it so it looks like it did in your video?

Capture.PNG

Re: Datum planes in a hidden layer will not hide in the model!

Interesting... mine have never done that.

You might try and see if this still happens if you do not use any custom config.pro or detail.dtl file.

I suspect it is a line style setting somewhere.

Re: Datum planes in a hidden layer will not hide in the model!

Alright I'll try that out. Thanks for the help!

Re: Datum planes in a hidden layer will not hide in the model!

What specific issue is the Datum plane created using the "old fashioned" causing?

There's a trick I can suggest that resolves the issue using the old "Set Datum" dialog box but it's only valid for specific types of issues. You should not have to set the datums as annotations to get them to work. We do this often and haven't seen an issue.

If you can explain I'd like to see if I can help.

Thanks!

-Brian

Re: Datum planes in a hidden layer will not hide in the model!

I'm not sure if I understand your question.. The issue is that the planes will not hide in the model no matter what I've tried (layers, etc.). I need them to show up in the drawing but be hidden in the model because otherwise it is difficult to properly see the part.

Also, I saw you responded to my other question about the annotations with the dashed lines. I created them exactly the way they are created in the video posted by Antonius Dirriwachter above.

Thanks