cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to Publish any Project

Unable to Publish any Project

I am currently unable to publish any project from Thingworx studio. 

 

When I try to publish I get the following error message. 

2018-03-13_15-00-31.png

 

 

[03/13/2018 14:00:15] info: [twx-studio:projectHelper] buildApp Sandvik_1520936936527already in progress. Trigger build after it completes.
[03/13/2018 14:00:15] info: [twx-studio:projectHelper] buildApp Sandvik_1520936936527already in progress. Trigger build after it completes.
[03/13/2018 14:00:16] info: [twx-studio:projectHelper] buildApp Sandvik_1520936936527already in progress. Trigger build after it completes.
[03/13/2018 14:00:26] Studio Version 8.2.0 (8.2.0.2742)
[03/13/2018 14:00:26] Status Message: Version 8.2.0 (8.2.0.2742)
[03/13/2018 14:00:26] Checking for updates from https://studio-download.vuforia.io/downloads/ThingworxMobileBuilderApp.application
[03/13/2018 14:00:27] Starting node.exe
[03/13/2018 14:00:28] info: [twx-studio:initializer] Node version: 8.9.3
[03/13/2018 14:00:28] info: [twx-studio:initializer] ThingWorxStudio launched with the following arguments: _=[C:\Users\rirelandbowcott\Documents], help=false, version=false, $0=..\..\..\..\..\..\Roaming\ThingworxStudio\studio-download.vuforia.io\dist\server\index.js
[03/13/2018 14:00:28] info: [twx-studio:initializer] ThingWorxStudio dir:  C:\Users\rirelandbowcott\Documents\ThingWorxStudio , home dir: C:\Users\rirelandbowcott\Documents
[03/13/2018 14:00:28] ar-extension version 8.2.0 (1.22.941)
[03/13/2018 14:00:30] info: [twx-studio:index] Studio Ready: listening on 127.0.0.1:3000
[03/13/2018 14:00:33] GET /%7B%7B::projectType.imgPath%7D%7D 200 3.943 ms - 2747
[03/13/2018 14:00:33] GET /%7B%7B::view.imgPath%7D%7D 200 3.506 ms - 2747
[03/13/2018 14:00:33] GET /%7B%7B$root.currentProject.thingServerQRCode%7D%7D 200 3.939 ms - 2747
[03/13/2018 14:00:33] GET /%7B%7BviewType.imgPath%7D%7D 200 1.022 ms - 2747
[03/13/2018 14:01:19] GET /%7B%7B::projectType.imgPath%7D%7D 304 3.030 ms - -
[03/13/2018 14:01:19] GET /%7B%7B::view.imgPath%7D%7D 304 4.003 ms - -
[03/13/2018 14:01:19] GET /%7B%7B$root.currentProject.thingServerQRCode%7D%7D 304 4.125 ms - -
[03/13/2018 14:01:19] GET /%7B%7BviewType.imgPath%7D%7D 304 4.812 ms - -
[03/13/2018 14:01:23] GET /api/switch 401 2.967 ms - -
[03/13/2018 14:01:23] GET /api/switch 200 0.179 ms - -
[03/13/2018 14:01:23] POST /api/unpublish/ 500 31.696 ms - 42
[03/13/2018 14:01:25] GET /api/switch 200 0.109 ms - -
[03/13/2018 14:01:53] GET /api/switch 200 0.212 ms - -
[03/13/2018 14:01:53] POST /api/unpublish/ 500 4.264 ms - 42
[03/13/2018 14:01:55] GET /api/switch 200 0.208 ms - -
[03/13/2018 14:01:55] POST /api/unpublish/ 500 1.737 ms - 42
[03/13/2018 14:01:56] GET /api/switch 200 0.097 ms - -
[03/13/2018 14:01:56] POST /api/unpublish/ 500 1.826 ms - 42
[03/13/2018 14:02:00] GET /api/project/Sandvik/zip/ 200 499.721 ms - 38114368
[03/13/2018 14:02:11] GET /api/switch 200 0.217 ms - -
[03/13/2018 14:02:11] POST /api/unpublish/ 500 4.889 ms - 42
[03/13/2018 14:02:58] GET /api/switch 200 0.274 ms - -
[03/13/2018 14:02:58] POST /api/unpublish/ 500 2.775 ms - 42
[03/13/2018 14:03:19] GET /home 200 0.957 ms - 2747
[03/13/2018 14:03:20] GET /%7B%7B::projectType.imgPath%7D%7D 304 0.813 ms - -
[03/13/2018 14:03:20] GET /%7B%7B::view.imgPath%7D%7D 304 1.668 ms - -
[03/13/2018 14:03:20] GET /%7B%7B$root.currentProject.thingServerQRCode%7D%7D 304 0.346 ms - -
[03/13/2018 14:03:20] GET /%7B%7BviewType.imgPath%7D%7D 304 0.362 ms - -
[03/13/2018 14:20:31] GET /api/switch 200 0.201 ms - -
[03/13/2018 14:20:41] GET /api/switch 200 0.289 ms - -
[03/13/2018 14:20:58] info: [twx-studio:projectHelper] Building ves-ar-extension app: Sandvik
[03/13/2018 14:21:00] info: [twx-studio:projectSettings] Notify preview windows:  private-room-Sandvik
[03/13/2018 14:21:23] info: [twx-studio:projectHelper] Building ves-ar-extension app: Sandvik
[03/13/2018 14:21:24] info: [twx-studio:projectSettings] Notify preview windows:  private-room-Sandvik
[03/13/2018 14:21:24] GET /api/switch 200 0.187 ms - -
[03/13/2018 14:21:24] POST /api/publish/ 500 25.276 ms - 42
[03/13/2018 14:21:33] info: [twx-studio:projectHelper] Building ves-ar-extension app: Sandvik
[03/13/2018 14:21:34] info: [twx-studio:projectSettings] Notify preview windows:  private-room-Sandvik
[03/13/2018 14:21:55] info: [twx-studio:projectHelper] Building ves-ar-extension app: Sandvik
[03/13/2018 14:21:56] info: [twx-studio:projectSettings] Notify preview windows:  private-room-Sandvik
[03/13/2018 14:21:56] GET /api/switch 200 0.195 ms - -
[03/13/2018 14:21:56] POST /api/publish/ 500 4.887 ms - 42
[03/13/2018 14:36:31] info: [twx-studio:projectHelper] Building ves-ar-extension app: Sandvik
[03/13/2018 14:36:33] info: [twx-studio:projectSettings] Notify preview windows:  private-room-Sandvik
[03/13/2018 14:36:38] GET /design/Sandvik 200 1.164 ms - 2747
[03/13/2018 14:36:40] GET /%7B%7B::projectType.imgPath%7D%7D 304 0.777 ms - -
[03/13/2018 14:36:40] GET /%7B%7B$root.currentProject.thingServerQRCode%7D%7D 304 0.842 ms - -
[03/13/2018 14:36:40] GET /%7B%7BviewType.imgPath%7D%7D 304 0.982 ms - -
[03/13/2018 14:36:40] GET /%7B%7B::view.imgPath%7D%7D 304 2.031 ms - -
[03/13/2018 14:36:40] GET /api/switch 200 0.141 ms - -
[03/13/2018 14:36:54] info: [twx-studio:projectHelper] Building ves-ar-extension app: Sandvik
[03/13/2018 14:36:55] info: [twx-studio:projectSettings] Notify preview windows:  private-room-Sandvik
[03/13/2018 14:37:27] info: [twx-studio:projectHelper] Building ves-ar-extension app: Sandvik
[03/13/2018 14:37:28] info: [twx-studio:projectSettings] Notify preview windows:  private-room-Sandvik
[03/13/2018 14:37:28] GET /api/switch 200 0.164 ms - -
[03/13/2018 14:37:28] POST /api/publish/ 500 15.745 ms - 42

 

6 REPLIES 6

Re: Unable to Publish any Project

Is this a trial instance? If so, what is the ES URL you are attempting to publish to? Can you share a screenshot of the info tab of the experience? Have you ever been able to publish experiences? 

Re: Unable to Publish any Project

Hi, 

 

Yes, this is currently a trial version although hopefully not for long and yes, I have been able to publish in the past so i'm not sure what has changed. 

 

Please see the screen grabs below. Hopefully they contain the information you wanted. 

 2018-03-14_09-04-15.png2018-03-14_09-10-58.png

 

Re: Unable to Publish any Project

Not to worry, our Trial has expired!

 

Looks like it's time to get our actual account up and running. 

Re: Unable to Publish any Project

I am also getting the same error as seen in attached log and am unable to publish my first project using the trial license. Were you able to find any solution with the trial license?

Re: Unable to Publish any Project

Our trial licence had expired which is what was causing the issue.
Highlighted

Re: Unable to Publish any Project

ok, thanks.

I will open a new post then for this issue.