cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Application configuration file open error

Highlighted
Newbie

Application configuration file open error

Hi all.what causes this error and how it can be removed.i get this error when i want to load Cro Parametric.

starting+problem.JPG

Tags (2)
24 REPLIES 24
Highlighted

Re: Application configuration file open error

I suspect your startup shortcut if incorrect. Do you still have the default Creo startup shortcut and does this function? Has anyone changed folder names or locations for the Creo install? Do you have multiple Creo installations? Is the path pointing to non-existing "earlier" installation?

I will suggest you start a case with PTC to confirm the install if you still have maintenance.

Highlighted

Re: Application configuration file open error

yea it is the shortcut.

it is not functioning.

No one has changed the forlder names.

yes i have installed creo 1 but that has a separate folder in a separate drive.i have uninstalled that but still a problem.

The path doesnot point so.

Highlighted

Re: Application configuration file open error

Are you installing any additional extensions? Have you tried to install to the default folder?

I know this is frustrating and it really should be a simple thing. I can tell you, although it will not help, that every installation has worked as long as I follow some basic steps: Uninstall completely; download the install program and help files (6+gb!) and extract them to an install folder in the root; create a Creo program folder; drag and drop the license file when prompted during install; step through the pages to include Mechanism extension (the default included version); provide my custom install path; install... and install the help files the same way. I test this with using the default icon on the desktop and no custom config.pro. with this procedure, it always boots up without issue. The 1st time it boots up, it has to install a few programs. This could be where your bootup is failing.

The only time the install failed is when I did an auto install over the web on Creo 1.0 F001.

If this continues, please contact customer support.

Highlighted

Re: Application configuration file open error

I have been having the same problem and am dead in the water.

We just upgraded to Creo 2.0 and cannot get it to open.

Application configuration file open error,

unable to launch application because no valid configuration (*.psf). etc, etc, etc,

Uninstalled everything that is PTC related, and re-installed manually to no avail.

It appears that Creo cannot find the parametric.psf that does exist in the parametric\bin folder.

Or there is something incorrect in the parametric.psf file itself.

I see that this question is "Not Answered".

Highlighted

Re: Application configuration file open error

I'm going to take a wild guess here but I will recommend you open a support case and have customer support walk through this with you.

My guess is that the PST file is the personal preferences file that exists somewhere in the user folders (not PTC folders). I know that as you upgrade, your personal settings are maintained. This is primarily the ribbon modifications. I don't know exactly where they are located, but you might need to remove this folder before installation of the application.

Highlighted

Re: Application configuration file open error

Antonius, thanks for your response.

This is an install from new - no custom or personal preferences.

The only .pst file on my computer is an Outlook archive file, so I don't understand how that could possibly connect.

I suspect a company controlled file someplace has something incorrect within, but to get our IT department to help is like a silboat without a rudder and a keel.

Highlighted

Re: Application configuration file open error

Marshall, you would do well to get the information from IT or the purchasing department to get access tot he PTC Support site. You need the support account number so you can sign up and from then on, you will get support from PTC through their site. Fully traceable and they are capable of helping you with a screen share (if allowed by your company). You can also submit files with non-disclosure if you have corrupt of problem files that you need PTC to look at or reference. I have worked at companies that shield the users from support sites. Now that I've used them, I can't see why anyone wouldn't want access.

However, you wouldn't be the 1st to have roll-out problem. It could be as simple as a wrong MAC address or problems with the way your registry reports the nic cards. Maybe the error message is a red herring. In this case, I would get with customer support or even you VAR to get this resolved ASAP.

Highlighted

Re: Application configuration file open error

It's looking for a *.PSF file, not *.PST. It's a "PTC Startup File" and it tells Creo Parametric what license to use upon launch and sets a bunch of environment variables. You need at least one and it should have been created when you installed Creo.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
Highlighted

Re: Application configuration file open error

Marshall,

I have never met such situation. If you can upload your parametric.psf file I can check its contents.

You can also try the following procedure:

  1. open Windows Explorer and browse into ...\Creo 2.0\Parametric\bin directory
  2. double-click parametric.exe

Maritn Hanak


Martin Hanák
Highlighted

Re: Application configuration file open error

Martin,

Thanks for your response.

Like you, I suspect that there is something written wrong in the process of our custom start up files.

We are bound by the IT department's controls during log in, and customization is most likely the culprit.

I am a distant installation from our main installation.

I wish I could install raw from a DVD, using all the defaults because I beleive it would function.

I am on day 3 with no real support from out IT.

My paramatric.psf minus the license statement (proprietary):

// PTC - PSF file: parametric
//
PRODUCT=Creo Parametric
DESC=Creo Parametric (default)
SHIPCODE=M040
CREO_COMMON_FILES=Common Files\M040
//
ENV=MECH_LP=%PRO_DIRECTORY%\mech
ENV=MECH_HOME=%MECH_LP%\%PRO_MACHINE_TYPE%
ENV=PRO_MECH_COMMAND="%CREOAPP_DIRECTORY%\bin\parametric.exe" "%CREOAPP_DIRECTORY%\bin\parametric.psf"
ENV=RPC_TIMEOUT=31536000
ENV=MEDI_HOME=%MECH_HOME%
ENV=PATH+=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\deflib
ENV=PATH-=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\lib
ENV=PATH-=%INTRALINK_DIR%\%PRO_MACHINE_TYPE%\illib
ENV=PATH+=%PRO_DIRECTORY%\libs\dfor\lib
ENV=NMSD_TIMEOUT=300
ENV=PRO_COMM_MSG_EXE=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\pro_comm_msg.exe
ENV=PROE_START=%CREOAPP_DIRECTORY%\bin\parametric.exe
ENV=CDRS_DATA=%PRO_DIRECTORY%
ENV=PRO_IMAGE_CONVERTER=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\convert_image.exe
ENV=PROGUIDE_DIRECTORY=%PRO_DIRECTORY%\uifdoc
ENV=SPG_DIRECTORY=%PRO_DIRECTORY%
ENV=PRO_USRMAIN=%PRO_DIRECTORY%\usrprog\umain\usrmain.c
ENV=PROTABLE_DIRECTORY=%PRO_DIRECTORY%\protable
ENV=MOZILLA_FIVE_HOME=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\MOZILLA
ENV=PROTAB=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\protab.exe
ENV=ZIP_EXEC=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\zip.exe
ENV=CLHOME=%PRO_DIRECTORY%\text\pcldata
ENV=PVIEW_PROEPVIEW_HOME=%PRO_DIRECTORY%\apps\prodview
ENV=CV_ENV_HOME=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\CV140
ENV=DEBUG_HLP_DLL_PATH=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\lib\dbghelp.dll
License statement was here
ENV=CREO_APP=PMA
ENV=CREOPMA_FEATURE_NAME=PROE_Flex3C PROE_Flex3CRG ()
RUN="%MECH_LP%\install\nt\pro_mech_env.bat"
RUN="%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\nms\nmsd.exe" -noservice -timeout %NMSD_TIMEOUT% &
RUN="%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\xtop.exe"
// USER - PSF
// Add User specific environment or run applications below here
ENV=DBG_NCPOST_PATH=%CREOAPP_DIRECTORY%\bin

Double clicking on parametric.exe does nothing.

Our Creo_Start.bat:

@echo off
cd\
cd PTC\Creo 2.0\Common Files\M040\text
del config.pro
copy "T:\common\Pro\configs\config.pro" "c:\PTC\Creo 2.0\Common Files\M040\text"
cd\
cd CreoWork\configs

"C:\PTC\Creo 2.0\Parametric\bin\parametric.exe" "C:\PTC\Creo 2.0\Parametric\bin\parametric.psf" %*

Exit

I have un-installed EVERYTHING that is PTC related, including the Environment Variables from Creo Elements, and re-installed manually using the controlled batch files from IT which is from their written proceedure.

Highlighted

Re: Application configuration file open error

Marshall,

did you test my two-step procedure ?

Martin Hanak


Martin Hanák
Highlighted

Re: Application configuration file open error

Marshall,

I found that double-clicking parametric.exe does nothing on your PC. It's strange ... It looks like parametric.exe cannot be executed on your PC for some reason. I can imagine only one possibility - you have 64-bit installation on 32-bit operating system.

Martin Hanak


Martin Hanák
Highlighted

Re: Application configuration file open error

Martin,

Your two step proceedure was to open Creo2.0 folder, then double click parametric.exe which I did and nothing happened whatsoever.

Note this:

The icon associated with parametric.exe is the generic windows icon, which appears that the exe is not properly associated, but is indeed linked to PTC.

Highlighted

Re: Application configuration file open error

Martin,

My system is 64 bit.

Highlighted

Re: Application configuration file open error

Marshall,

go into Creo 2.0\Common Files\M040 directory and look for the following subdirectories

i486_nt

x86e_win64

Are these directories present in you installation ?

Martin Hanak


Martin Hanák
Highlighted

Re: Application configuration file open error

Martin,

i486_nt is missing.

Highlighted

Re: Application configuration file open error

Marshall,

it's OK.

i486_nt is present in 32-bit installation

x86e_win64 is present in 64-bit installation

Martin Hanak


Martin Hanák
Highlighted

Re: Application configuration file open error

Marshall,

your psf file is OK.

Your Creo_Start.bat is also OK:

  • it must be located on C: drive
  • I think Exit command is not necessary

So the main problem is ... "double-clicking parametric.exe does nothing". Unfortunatelly I don't know how to resolve it.

Martin Hanak


Martin Hanák
Highlighted

Re: Application configuration file open error

Martin,

Thanks for the review of the files.

Yes I agree that Exit is not needed, but I am not at liberty to make change at this time.

I am concerned that our IT cannot resolve the problem either.

If I click on reconfigure.exe what will I experience?

Highlighted

Re: Application configuration file open error

Marshall,

reconfigure.exe launches installation manager. I never use it. I think you can use it if you need to define new startup command (psf file) of modify existing one.

I have no idea how to help you. I give up...

Good luck

Martin Hanak


Martin Hanák
Highlighted

Re: Application configuration file open error

Martin,

Thanks for trying, I have to sit and wait for our IT to respond unfortunately.

Highlighted

Re: Application configuration file open error

We have determined that the installation files on our network are corrupted and are attempting to refresh the files.

Hopefully this will solve the problem.

Installation across out network is probably the worst way we can attempt this, but its the process we must abide by.

Highlighted

Re: Application configuration file open error

Marshall,

I think it is logical that your installation does not work because installation files are corrupted.

BTW ... copying files over the network is usual way I use when I install ProE/Creo on several computers.

My procedure (litle bit simplified):

  1. I create exemplary installation on first PC
  2. I create zip archive
  3. I copy zip archive on another PC
  4. I unzip it

Martin Hanak


Martin Hanák
Highlighted

Re: Application configuration file open error

Hi Martin,

You have described our process also.

Problem is today that the zipped file is corrupt and it took over 5 hours to transfer through our T1 internet.

Announcements