Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Stay updated on what is happening on the PTC Community by subscribing to PTC Community Announcements. X

Creo 2-m020, no learning connector???


Creo 2-m020, no learning connector???

I have a call open with PTC and am getting nowhere in getting it solved.

I have Creo 1.0-m050 installed. When I run it I get the following processes that run:

In the upper right corner of Creo I see the Learning Connector icon.

I also have Creo 2.0-m020 installed. When I run it I get the following processes that run

The Creoagent doesn't run.
The Learning Connector icon doesn't show up.

If I start Creoagent first, and then start Creo 2.0 it still doesn't work.

I have Creo 2.0 installed onto a network drive and I used the silent installer to install all the local stuff, including the creoagent. Like this:
rem ** Install the client Side software
rem "P:\Creo 2.0-m020\Training_Setup\creoagent_32_64.msi" INSTALLDIR="C:\ptc\Creo 2.0\creoagent" /passive
rem "P:\Creo 2.0-m020\Training_Setup\Thumbviewer_32_64.msi" /passive
cd /d "P:\Creo 2.0-m020\Training_Setup
start /w CreoView_Express_32_64.exe /vADDLOCAL="ALL" /qn APPLICATIONFOLDER="C:\ptc\Creo 2.0\CreoViewExpress"

rem ** Install the registry settings
regedit /s "P:\Creo 2.0-m020\Training_Setup\direct-created.reg"
regedit /s "P:\Creo 2.0-m020\Training_Setup\parametric-created.reg"
regedit /s "P:\Creo 2.0-m020\Training_Setup\simulate-created.reg"

Anyone have an idea??????????

David Haigh
Phone: 925-424-3931
Fax: 925-423-7496
Lawrence Livermore National Lab
7000 East Ave, L-362
Livermore, CA 94550

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.

I spent 45 minutes on the phone with PTC. I thought I understood it all, but after trying to write a script to automate the fix. I discover that everything isn't exactly as they told me.

Here's what I know for sure:
If you let Creo install the creoagent.exe in the default location down in the %APPDATA% folder, then the learning connector works.
If you define a custom location for the creoagent.exe, then the learning connector doesn't work.

I've re-opened the case.

David Haigh

So my call finally got transferred to the installation guys, instead of the learning connector guys.

They were able to reproduce my problem and I now have an SPR for it. SPR 2157073

Bottom line, if you are installing the creoagent, it has to be installed in the default location. If you don't do that then the learning connector will not work.

This doesn't work:
rem "P:\Creo 2.0-m020\Training_Setup\creoagent_32_64.msi" INSTALLDIR="C:\ptc\Creo 2.0\creoagent" /passive

This works:
rem "P:\Creo 2.0-m020\Training_Setup\creoagent_32_64.msi" /passive

Problem is, both methods are shown as valid in the install guide.

David Haigh

A follow up on this issue. Last week while I was out, PTC got back to me saying this:

Hi Dave,

As per our R&D, Creo Agent is currently designed to work only if it is installed at default location. However, we are working on this to enhance in future releases of Creo.

So just because the install guide says you can put it in a custom location, you really can't.

David Haigh
Top Tags