cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creo Parametric 3.0 M010 not starting

istark
Newbie

Creo Parametric 3.0 M010 not starting

When I try to run my Creo Parmetric 3.0 M010 it doesn't start. I went into the task manager and saw the process start and fade after a few seconds. I tried to run it in as admin, to uninstall and reinstall, I'm completely lost.

I'm running on a lenovo G510 with windows 8.1

 

Thank you anyone that can help!

20 REPLIES 20

Re: Creo Parametric 3.0 M010 not starting

Are any files created in the start-in folder? (See shortcut properties for start-in location.)

Re: Creo Parametric 3.0 M010 not starting

What kind of files?

I mean there are files there (it's the c:\users\public\documents folder), but I'm not sure it's the files your'e talking about

Re: Creo Parametric 3.0 M010 not starting

std.out and/or trail.txt Either one of these may give a clue to what is going on.

Re: Creo Parametric 3.0 M010 not starting

There is like a thousend trail.txt files, and there is also a std.out file.

The std.out file contains the following line:

Old Intel Graphics driver found; Disabling FBO. Please update your driver

thos this help us in any way? What is FBO? how can I update my driver?

Re: Creo Parametric 3.0 M010 not starting

Take a look at this knowledge base article: CS156839 (assuming you have support). This was written for Creo 2, but it sounds like it may apply.

In case you can't read it, try setting enable_opengl_fbo to no in your config.pro file (either in the loadpoint or in the start-in directory).

Re: Creo Parametric 3.0 M010 not starting

Thank you for all the help!

Unfortunatly, I can't read the article,

I did find the config.pro file, but the problem is I found about 3 of those, and non of them have the enable_opengl_fbob setting. They we're all in the creo's Common Files folder

Thank you again!

Re: Creo Parametric 3.0 M010 not starting

Attached is a simple config file with only this one command. Rename it from config.txt to config.pro and then drop it into your start-in directory (again, look at the shortcut for this location). Re-launch Creo and let me know if it makes any difference.

Re: Creo Parametric 3.0 M010 not starting

Okay, I didn't realize it was going to zip it. You will need to unzip it first, then rename it.

Re: Creo Parametric 3.0 M010 not starting

I tried what you said, but it seemed to be no different. Is there anything else that can do the trick?

Thank you again for everything

Re: Creo Parametric 3.0 M010 not starting

Maybe this will help

Here's what the lastest trail.txt file in the start-in directory says:

!trail file version No. 1800

!Creo TM 3.0 (c) 2015 by PTC Inc. All Rights Reserved.

!Exit Logger data:

! Process ID: 5320

! Application: Creo_Parametric

! Start date&time: 2015/02/04 16:51:26

! language: usascii

! machine type: x86e_win64

! datecode: M010

! Server: NONE

! Workspace: NONE

! traceback file: C:\Users\Public\Documents\traceback.log

!end Exit Logger data.

< 0 0.846222 1220 0 0 714 1366 0 0 768 13

!mem_use INCREASE Blocks 613467, AppSize 60157999, SysSize 71896816

< 0 0.622222 1109 0 0 525 1366 0 0 768 13

< 0 0.622222 998 0 0 525 1366 0 0 768 13

!%CIWelcome to PTC Creo Parametric Educational Edition 3.0.

~ Close `SA_BROWSER_WELCOME_SCREEN` `SA_BROWSER_WELCOME_SCREEN`

~ Activate `main_dlg_cur` `EMBED_BROWSER Close`

~ Timer `UI Desktop` `UI Desktop` `EmbedBrowserTimer`

< 0 0.618667 998 0 0 522 1366 0 0 768 13

~ Close `main_dlg_cur` `main_dlg_cur`

!Command ProCmdOSExit was pushed from the software.

! Message Dialog: Warning

! : PTC Creo Parametric Educational Edition will terminate and any unsaved work will be lost.

! : Do you really want to exit?

~ FocusIn `UI Message Dialog` `yes`

~ Activate `UI Message Dialog` `yes`

!End of Trail File

Thanks again!

Re: Creo Parametric 3.0 M010 not starting

This is from 2015/02/04, a few days ago unless your computer clock is way off.

It would be funny if someone built a macro that closes Creo as soon as it opens. Or maybe not so funny if you are trying to get work done.

Re: Creo Parametric 3.0 M010 not starting

Do you mean it's some sort of another program that starts with creo and closes it?

How can I fight this?

Re: Creo Parametric 3.0 M010 not starting

Your trail file showed that a dialog box warned that Creo would exit and someone selected "yes"

Try running Creo again and see if there is a new trail file that is created and post the contents. Check to see that the date is correct.

So far there isn't enough information to be sure what's wrong, but I'd start by adding "graphics win32_gdi" to the config.pro file and searching here for more info on Intel HD Graphics 4600, such as Creo 2.0 and Intel HD 4600 graphics

Re: Creo Parametric 3.0 M010 not starting

A new trail.txt file is not created, so that those trail.txt files are probably a left over from when the program was working

Re: Creo Parametric 3.0 M010 not starting

Idan,

trail file is not created if Creo crashes too early. Try to think whether your computer current "condition" is the same as the previous one (in times when Creo was working correctly). May you disabled network card, updated some drivers, ...

Martin Hanak


Martin Hanák

Re: Creo Parametric 3.0 M010 not starting

Thank you.

The computer was running some updates like always, it may have caused the change. But it ran so many of them that I can't know which one caused it

Re: Creo Parametric 3.0 M010 not starting

Hi guys, I still have no ideas how the hell to fix it

Anyone who can help will be of great... well, help.

Thank you!

Re: Creo Parametric 3.0 M010 not starting

Hi,

it is difficult to help you, because "I am not sitting at your computer". Maybe you can try to install Creo on different computer.

Martin Hanak


Martin Hanák

Re: Creo Parametric 3.0 M010 not starting

It would be nice if PTC included a startup-logging mode so that each step was recorded for start/execution/completion; preferably with full path names to components and services that it apparently assumes are in place. It's possible to do some of this with the Sysinternals, but I've never used them enough to be all that good at diagnosis Windows Sysinternals: Documentation, downloads and additional resources

This is a link to Mark Russinovich's blog (the guy who developed the Sysinternals to begin with) about detecting and fixing software execution problems. It's a good read no matter what. Mark's Blog Index

Re: Creo Parametric 3.0 M010 not starting

I was also struggling with the same issue, Creo 3.0 M060. Tried everything, reinstalled thrice and cleared all registry entries related to PTC. No luck.

But, at last I found a work around. I got so frustrated and kept on double clicking on the program shortcut on the desktop. To my surprise, Creo started up and everything was running fine. But, now everytime I want to startup the software, I keep on double clicking until I see the application opening up.

Hope that helps someone struggling with the issue.

Announcements