cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics regenerate very SLOW

Highlighted
Newbie

Graphics regenerate very SLOW

I am using Creo 2.0 when I first start a drawing the Front Top and Right view line are jagged and after a few minutes it would look normal. . When I drag my mouse on the drawing it leaves xxxxx. Then when I extruded the a circle it took several minutes to extrude completely. All the commands are running very slow.

I have an HP Pavilion dv7 I5 processor 6 GB memory.

Any suggestions would be Great.

2 REPLIES 2
Highlighted

Re: Graphics regenerate very SLOW

Symptoms

ghosted dialog boxes
black backgrounds
mix of shaded and wireframe model display
everything is flipped over the horizontal axis
break lines
partial view splines visible
broken projected view

Fixes

1) Update display drivers

Make a Restore Point, or full backup before updating graphics drivers
make sure you understand how to use the Restore Point or backup to restore your operating system and data
Look for drivers from the makers of the computer first, then the maker of the card, finally from the maker of the operating system
Note: sometimes the most compatible graphics driver version is not the latest version. Be prepared to look for and try older versions.

For AMD/ATI cards try http://support.amd.com/us/gpudownload/Pages/index.aspx (external link)

2) Avoid using hardware acceleration
Mostly avoided by setting the config option "graphics win32_gdi"
Alternatively try "graphics d3d" for Creo 1, Creo 2, Creo 3

Also possible to add startup command option
1. Right Click on software (Creo) shortcut icon > Properties
2. Click in Target path and move cursor to extreme right (at the end of .....exe")
3. Add a space after .exe"
4. Type -g:win32_gdi > Apply > Ok

3) Use hardware acceleration, but disable some features (try one at a time)
May also benefit from the following config options, Creo Parametric 2.0 M090 and higher:
enable_opengl_fbo no
enable_opengl_vbo no
enable_opengl_shader no
ref http://communities.ptc.com/message/244856#244856 (external link)
Note: fbo = frame buffer object; vbo = vertex buffer object; shader is shader object.
These are part of later versions of OpenGL.

4) For better performance with win32_gdi, try setting the display to 16 bit in the OS system manager.

Highlighted

Re: Graphics regenerate very SLOW

David,

Did these suggestions improve performance?

Announcements