cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Intent objects?

DarrinHiebert
1-Newbie

Intent objects?

I was going to investigate using some intent edges today, something that
we have never really done in the past.



We are on Creo/Elements (WF5) M070.



Whenever I try to add a reference feature, I get this error:







I have added this to our base config. I have manually regenerated this
model. I have even gone into model player, checked regeneration, and
regenerated every feature one by one, and I still get the same message.



What am I missing???



This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
12 REPLIES 12

Setting the option and regenerating from the beginning with the model
player should do it. Did you try restarting Pro/E after the option was
set? Some options require a restart to take effect.



Doug Schaefer
--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn

Yeah, I did that as well, and that didn't help either. I forgot to
mention that in my first email.


The other thing that I forgot to mention is that the seat that I'm trying
to do this with is a Flex 3C seat (or what used to be a called that).



I just tried WITHOUT using our start part, and it works. Does this mean
that I need to go in and redefine our start part so that it's compliant???


Chances are you are trying to pick a feature that is created in an old version of Pro/E. You can only use intent objects on features that were created after the functionality is in the code. You cannot update a model to a later rev. (Please, I am not trying to start a firestorm of conversation.). In all Pro/E models, the code that created the feature is saved. When the model is regenerated it uses that same code. This way it is assured that the geometry is exactly the same from revision to revision. Yes, this means that if you created a part in version 2 of Pro/E, it still regenerates using that version even if you are on Wildfire 5.0.

Sorry, I don't think that there is a way around this and you have to use intent features on newly created features.

Ronald B. Grabau
HP PDE-IT
Roseville, CA
916-785-3298
-<">mailto:->

If your start part dates back to before intent objects were introduced
(in Rev. 2001, I think), then yes. It sounds like it does.



Still, after the part is created, if you roll it all the way back with
the model player and click 'regen features' and the roll to the end,
it's supposed to fix it. That's how you'll fix your start part too.



Doug Schaefer
--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn

Ron,



Actually, PTC documented the means of upgrading a model in this
--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn

Ron,



Thanks for the reply!



I have tried creating entirely new models that have ALL new features and
that doesn't help either. But, I think that your point is still valid,
since the very FIRST feature in this model is a datum plane, and that
datum plane was created in Rev 19? probably. Needless to say, it's been a
while. So that's where it's reading the first feature from.


Doug,



Thanks for this information!!



Strike 1 on the first link. That didn't work.



.and.



Strike 2 on the second link. That's basically a reiteration of link 1,
but specifically dealing with rounds.



I have verified that it when I use the default PTC start parts, I have
access to the features. However, no amount of regenerating, with or
without model player causes my model to be saved as a WF5 model, and
that's where the hang up is, I think.



My problem is multi-folded.



. I didn't create our original start parts, so I'm not totally for
sure what all is in there. I can recreat everything by comparing it to
our current one, and I would just have to hope that I catch everything

. I have NO clue when we updated these things last, and what
revision they were originally created on. If I had to guess, I would
guess that our current start parts could actually be as old as rev 17/18.
THEY ARE INDEED OLD!



Thanks again for everyone's help!!!


I think I'd file a case with PTC, citing the first link that says that
should work and see what they can do with it. It should update, based
on that info, but it's not. They may have some internal tools at their
disposal that can fix your start parts for you. Of course, that may
take some time.



Doug Schaefer
--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn

That's my next step. 😉



I also took our original start parts, and deleted EVERY feature in there,
and I still couldn't get them to take as WF5 parts.



I'll see what they say, and what they come up with for a solution. I
would really like to convert our current start parts, so that I don't lose
anything, but if that is something that I have to do, I'll do that.



Thanks for the help!!!


Stupid idea:

copy all the features but the first datums.

Paste into a model with datums that have the same names.

Worst that can happen is it doesn't work 🙂

Rui



On 12.06.

After talking with several of you offline (THANKS very much!), and trying
several things, we are going to submit this to PTC to see what they say
about how to handle "old" parts that you may want to convert.



I'll post a summary when I hear back from them about how to get this
accomplished, if at all.


Announcements
Attention: Creo 7.0 Customers
Please consider upgrading
End of Life announcement here.

NEW Creo+ Topics: PTC Control Center and Creo+ Portal