cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about PTC Community Badges. Engage with PTC and see how many you can earn! X

Shade_quality help

ChastainBruce
4-Participant

Shade_quality help

I have a Creo Parametric 2 user who wants to set his shade_quality higher than 10, but when he does so it's causing the movment to slow a lot and sometimes causing crashes. Below are the specs of his computer, do you thing that the graphics card is too weak here? or any other thoughts on this subject?

Dell Precision T7500, Xeon W5580, 24GB RAM, NVIDEA Quadro FX3800, Windows XP64

thanks,

bruce

3 REPLIES 3

Hello Alfred and welcome to the forum.

I suspect he also has a few other settings max'd out. I can max out the settings on simple assemblies for short periods of time to get screen shots without to much issue on a Precision M6600 with an I7 core and the Quadro 3000. You just have to be patient about moving the graphics on the screen.

I've seen Creo 2 crash from increasing the shade quality. This is becuase the increase in geometry accuracy/polygons through that setting also increases the amount of RAM required to hold the information. Increase it too much and you'll run out of available RAM and start using virtual RAM (page file) which will cause a huge hit. Increase it too much beyond your available amount and creo can crash on you. If you are working with very large models and playing with shade quality (or other options mentioned below), keep an eye on the amount of available RAM. The amount of VRAM (video ram) may also play into this but I've never played with it that much to get a feel if there are limitations, if any.

Transparancies, anti-aliasing/smooth lines, and "shade very small surfaces" in the model(s) can place a huge load on the GPU. Turning off transparency can greatly speed up large model manipulation while still increasing shade quality. Same with changing edge display quality and anti-aliasing. I've set up mapkeys to turn on/off transparencies and "shading with small surfaces" in very large models for quick manipulation on the fly. In summary you can play with increasing shade quality while decreasing or turning off the following options and keeping an eye on available ram and see if it gets you where you want:

  • Transparency (turn off or set to stippled) - Options --> Model Display --> Shaded model display settings
  • Edge display quality (decrease) - Options --> Entity Display --> Geometry display settings
  • Anti-aliasing (decrease or turn off) - Options --> Entity Display --> Geometry display settings
  • Show smooth lines (uncheck) - Options --> Entity Display --> Geometry display settings
  • Shade very small surfaces (uncheck) - Options --> Model Display --> Shaded model display settings

And don't forget that by default, saving parts with Shaded (and LODS) while the setting are set to high quality increases your file size as well. See the config.pro setting: save_model_display and set to wireframe

Top Tags