Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Help us improve the PTC Community by taking this short Community Survey! X

Start an asynchronous Application


Start an asynchronous Application

Hi All,

i feel like i am missing a step somewhere and i need help working out what i am doing wrong.

1st. i am an experienced coder, however, most of my time is spent in C# so i am confident i know how to code what i need to.

i just need to know how to compile and run an async application????? (J-Link)

here is what i have done so far..


  1. I am using the following command to compile my java application
    C:\DEV-LIBS\JavaJDK_8_144\bin\javac -cp "C:\DEV-LIBS\Creo\Common Files\text\java\pfcasync.jar"

    this seems to work correctly and the Java File is compiled correctly
  2. Now when i run the tool
    C:\Temp>java Sample

    i get an error saying.
    Error: A JNI error has occurred, please check your installation and try again


any help would be appreciated




I can't tell from your email if you are just trying to run some sample code to get the basic interface working for a previous synchronous application, or writing something new.


Just as a suggestion... IF you are working on a "new" application and you want to be asynchronous...   Check out CREOSON - it is FREE and uses JSON transactions for a LOT of common things.  Maybe easier and faster to get up and running with for whatever you are trying to do in the end.


Hope this helps!


Thanks for the quick reply.

let me clarify.

i am just trying to run the class, it is a very simple application (at the moment all i want it to do is open a drawing in Creo)

once i can run a simple app i will have no issue writing the code, i just can't get .class to run. (i have also tried .jar, with the same result)

i am on a windows PC with creo3.0. 

i am attempting to compile and run the application through cmd.exe

as i mentioned, i can compile ok however (it seems) however i am not able to run the application.

see attachment for error.

Anyone have any idea what the issue is?

I think you missing some of your loosely linked Librarys.


So I use a starter to startup with the right environment variables you need to run async connected tools.You can start and use the starter with ....exe -d to start it in development mode and push in your startcommands.


After that I compile with the pfcasync.jar and just start it.




If you already like C# you can also programm async Toolkit (C) or Object Toolkit (C++) Dlls and start them from C#. I have done that and it works like a charm. So you can program the UI in C# and make the logic inside an async dll. Start it with a sync Dll and you have a perfect starter with and output of the connection stream.


Only flaw is that you need a TK license to unlock your TK aplication parts (sync and async dlls).




NEW Creo+ Topics: PTC Control Center and Creo+ Portal