Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Stay updated on what is happening on the PTC Community by subscribing to PTC Community Announcements. X

Updating versions


Updating versions

I updated my Creo 2.0 F001 to M010.

Is there a way to make sure everything that was installed before is re-installed?

I had to load the Direct Modeling Converter (interfaces) from the disk because you can't add it through the batch file.

How do I keep this from happeing next time I do an update?

Not sure if Mechanism was loaded either. It too had to be added after the fact. But that was doable from the batch file.

I've never experienced this much pain in a product update!

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.

Hi Antonius...

I believe there is a way around having to go through these installs a second time but it requires a good knowledge of where these other files are kept and how Creo uses them. What I'm saying is... I think it's possible to circumvent the extra installs although most people do not.

I find myself just reinstalling everything and bundling it all up into a package (like a self-extracting zip file). We then distribute that file to our users and have them extract the file which recreates the directory structure of the original bundle. All the files go in their correct places and the applications work without any additional configuration. But... I still do the entire install fresh with each new update.

Also... most companies I've ever worked for don't update that often unless there's a specific bug fix we're interested in. For example, we worked with M090 of Wildfire 5.0 for almost a year even though newer versions were released. We only update about once a year to minimize this kind of pain.

I can see PTC is working on their installation software. I hope they're addressing this type of issue. I think we're not there yet though.

Just my two cents.

Best regards,


I've been in CAD since ComputerVision 4X which ran on workstations and had 300MB 15" platters for data storage. It was a -great- system that let any engineer worth their salt do great designs and full ANSI compatible drawing. It was a dream machine in its day!

I have never left the CAD environment since. Some software I looked forward to upgrades (Cadkey comes to mind) and then other were absolute dread, PTC included.

I recently did a bunch of work on 2000i. Quite stable and very functional for my line of work. If I could load it on Windows 7 as it loaded on NT 4.0, I would be in heaven. But alas, I have to pick a version of Pro/E I can move forward with. No one is breathing down my neck for a particular version so I figured Creo 2.0 was the "update" from Creo 1.0, which I did work with for about 3 months. I figure, "...what could they screw up so bad from a V1?" Silly me.

It took a while for support to get back to me and I am on a short deadline so I opted for a big gamble; use the Windows 7 uninstall of a few of the programs and try a re-install from the disk (F001). Other than some things not showing up right, it seems to have worked. At least, my mission critical function is back up and running.

If you recall, it was the small features in a large part (relative accuracy) that had me update. Turns out that wasn't the problem. I had worked all day modeling on M010 and things were going very smooth, until I needed to import a .pkg file and the option didn't exist any more.

I lost better that 6 hours today. I had to download the full M010 zip file (4.5Gb!) and run the install only to find out that as far as my installer was concerned, the Interfaces/Direct Modeler Converter was already installed.

I had to go for a bike ride before I destroyed my pretty little laptop.

When I got back and support still hadn't called, I opted for the disk install for the downgrade. The service calls and asks if I can upgrade again to try a "hidden option". Dude! I'm working on a deadline. So I ask support to duplicate my issue on -their- time and -their- machine. This fellow was almost surprised I only had a single license! (?)

I asked that the case remain open and report back how I can successfully install M010 without loosing the import capability.

The install was also a bit messy the 1st time. I had F001 and M010 help installed, and two versions of Creo Platform (2.6 and 2.9) which I have no idea what they are and was afraid to remove them.

I will never pretend to be a computer admin geek... nor a half decent IT nerd. I am an engineer that wants their software served well done

So what -is- the most stable version and revision in recent years?


just FYI ... my basic rule is Never do UPDATE installation. I always do new installation.

This means:

If I install Creo 2.0 F001 ... I use C:\ptc\Creo2_F001 installation directory

If I install Creo 2.0 M010 ... I use C:\ptc\Creo2_M010 installation directory

Martin Hanak

Martin Hanák

I've been spoiled with decent software in recent years

I can honestly say that my experience with PTC's software today is as bad as its ever been. I'm hoping to get a stable version and just forget about it soon enough. Getting back in the fold has cost me a lot of time, and time -is- money; frustration from purchase delays and license delays, and functional delays..., and it is leaving a really bad taste in my mouth with PTC's dedication to providing a quality user experience. I can see how the -other guys- are getting such a huge market share from the sole proprietorships.

When M020 comes out, I might try just starting over. I have to preserve the license management because tech support recently downgraded that so my license would quit hanging. I don't want to have to figure that out again.

The next challenge will be downgrading to a WF version when I have to remain client compatible.

Wow... I hope tech support is better than my experience on this one. Yesterday I was -very- clear with my situation and today I get a absolutely bogus reply to do exactly what I had already confirmed I did.

I think my install is completely hosed now. I lost my context sensitive help and my installed programs folder for PTC is a real mess. Oh well. Time to order yet another set of DVDs.


Can you download the latest software from Maybe someone already asked this (and if so, I apologize). Downloading is much faster than waiting for DVDs.

Also, if you're having issues with PTC customer support, you can always request to escalate your call. This is a way to let someone know you're still having a problem that needs attention. If you escalate your call and still don't get the support you need, please come back to the forum and let us know. Some PTC customer support people were responding to requests for assistance from users on the forums. If you are having trouble with customer support, I'm sure we can contact those people and get someone to work with you.



Indeed, that was the jist of my reply as well, Brian.

As an update to my situation, I really needed the drawing bug fixes of M010 and opted to follow Martin's advice.

I scrubbed everything from Windows 7 Programs and started over with a fresh Creo 2.0 M010 install.

I could not remove (uninstall) the Portmapper and left the PTC License Server alone.

I installed in a unique folder off the root of C: and opted out of the Quality Agent.

I don't know what all those optional extentions are but I decided to just put them all in just in case that was part of the problem. And I remembered to install the Mechanism option.

I am happy to report that Creo 2.0 M010 works fine at importing CoCreate/Elements Direct models again.

Thanks guys!


yesterday I removed Portmapper on customer PC using the following steps:

1.] in Task Manager I showed process of All users and killed portmap.exe (Maybe you can also find Portmapper among Services).

2.] I went to list of installed programs (via Control Panel) and uninstalled Portmapper

Additional info - after fresh installation I am doing the following steps:

1.] I uninstall PTC Quality Agent

2.] I "hide" the contents of C:\ptc\Creo2_M010\Creo 2.0\Common Files\M010\install\addon directory.

This means I create subdirectory named eg. SOMETHING in C:\ptc\Creo2_M010\Creo 2.0\Common Files\M010\install\addon directory and move pvx* directory and *.msi files into SOMETHING directory.

Martin Hanak

Martin Hanák

Martin, can you expand on that thought?

What is portmapper and what does it do?

What is the reason for moving the files in the addon folder?

Thanks again for helping me out here.


I do not know much about portmapper and addons ... just couple of notes ...

1.] portmapper

I think I do not need this software, in the past it was related to Pro/INTRALINK

2.] addons

I moved addons, because I want to disable Creo to install them automatically.

Martin Hanak

Martin Hanák

I accendently delete portmapper file after uninstalling creo 2.0 but now i want to install creo 2.0 again but portmapper wouldn't install and installation got failed.So what to do?URGENT

Top Tags