Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you know you can set a signature that will be added to all your posts? Set it here! X

flexLM boggart


flexLM boggart

Greetings all,

It seems that every time I launch Pro/E on my laptop, flexlm is not able to serve a license because "no license file is found". I go to setup and re-point flexlm to the license.dat that resides in the default folder and Pro launches fine... But then, next time, same thing.

WF2 M280, XPP SP3 x32

LMTools 10.8

Any thoughts on this?





Disable your Wi-Fi.
Then reboot.
My laptop seems to make the Wi-Fi the primary IP address.
This address isn't the same as my wired IP address.
Only one IP address can be called the machine IP address.

If the Wi-Fi address is associated with your machine, it won't be able to find your license.

To do this, right mouse click My Computer>Hardware Tab>Device Manager.
Find your Wi-Fi device and disable it.

Harry L. Archer Jr. (Code E26HA1)
Naval Surface Warfare Center
Indian Head Division

There is a way to fix this in the registry. I do not have the info in front
of me but search the web or on PTC support that is where I got this
information sometime ago.. It is a simple regedit manipulation to change a
number of your network card to 1 and the other to something else.


On Wed, Aug 24, 2011 at 8:02 AM, Archer, Harry L Jr CIV NAVSURFWARCENDIV <> wrote:

Hi guys ? thanks for the feedback. I am aware of the adapter sequence issue
in the Windows registry that you are referring to. I actually have that
registry key address saved in Evernote because I use it every so often and
am so sick of searching the archives for it.

This is not my problem ? Pro/E and flexlm will run fine and the license I
use is fine ? what happens is that the license.dat file that I point flexlm
to will regularly become ?invisible? to flexlm. Pro/E will not run claiming
that the license file is invalid. Then I run ptcsetup in the flexlm bin
folder and point the setup to the same license.dat file and finish setup and
then everything is fine once again.

Something is causing flexlm to stop seeing the license file as good.

So, I just need to reset it occasionally (not every time)? Pro/E has given
me larger pains in the past. I can live with this one?



I have seen similar loss of dat file, but it has only been when loading and
playing with the license server. Our server uses Flexlm for Pro/E,
Edrawings, and CFDesign so anytime one of them changes or gets updated I
have a heck of a time getting them all to play together and in the end it
works but never exactly how it should. It would be hit or miss if i wanted
to start or stop any one of the servers as it has never seen all three of
the license codes in the menu choices of the flexlm GUI. I wish it were
easier to add another code through the GUI but the only way I have been able
to do anything like that is through a Flexlm install. What has worked best
is to install the newest flexlm service last. Usually that is edrawings as
it updates more than the other two. This over writes the others and seems
to work. But it is not always clean.



Have you tried setting the environment variable LM_LICENSE_FILE to your license file c:\path\license.dat

I used to run several differentprograms that used FlexLM and sometimes they would not run with Pro/E running unless I added the environment variable.

Kenny Mc

Top Tags