Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Want the oppurtunity to discuss enhancements to PTC products? Join a working group! X

license failure


license failure

OK, I need some assistance.  After using Pro E/Wildfire/ CREO for many years I still am easily confused by the license for this software.   

1.  I turned my computer off due to heavy storms in the area.  CREO 4.0 was working fine.

2.  This morning I restarted my computer, CREO failed to find the license server, which is my computer, not on the server.

3.  MathCAD Prime is on the same computer and the license is the same file, but comes up fine.


I need CREO to get back to work of projects.....  HELP.



Is this a student license or full version?


If it's the full version then is the Flexlm service started?

this is a full version, not a student version.



What is there in error message? Add a snapshot of error... 


-15 Cannot connect to license server system.
The server (lmgrd) has not been started yet, or the wrong port@host or license file is being used, or the TCP/IP port or host name in the license file has been changed. 


I didn't change anything, only restarted the computer.  Can you guide me to the LMGRD?  If may need to be stopped and restarted, but it has been so long since I have done this I"m a bit fuzzy and getting older....  🙂


I vaguely remember going to the license manager and doing a restart.



Do you have license on same machine? If yes, just try rebooting the machine once. Still if it fails..check if license manager service is up and running, you can check that by accessing Details tab in Task Manager and check for ptc_d.exe and lmadmin or lmgrd.exe. 

Yes, the license is on the same machine.


Have rebooted twice.


checked details and ptc_d.exe and lmadmin or lmgrd.exe  were not running or listed.

CREO was listed so I deleted and retried but still the same message.


However MathCAD Prime still comes up.

If FlexLM is on your computer, the reboot should have started it.

You might try another reboot to see if that does it.


If not, then the FlexLM web interface program (log in as admin) should have a stop and start of the lmgrd.



Your questions worked me through it.... I went to the directory file for lmadmin.exe and executed it.... the program came up.  Apparently the restart or reboot didn't do it but CREO is functioning.   Thanks...


You may mark reply from @BenLoosli  as solution for this post. 


just FYI if you use Windows 10 operating system.

"Big" Windows 10 update (the last one was executed on 21-July-2019) removes Creo license manager service from the system and you have to uninstall/install FLEXnet ... every six months... 😞

This problem is known for 2 years and Microsoft still did not resolve it.

Martin Hanák
Top Tags