cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

reinstalling of Flexnet LM not working for Creo 3

SOLVED
Highlighted
Visitor

reinstalling of Flexnet LM not working for Creo 3

Hi,

Creo 3 licensing became unreliable with windows 10 and now completely stopped working. That means I can not use the software anymore. My reseller suggested me to reinstall the flexnet. The deinstalling went fine using the config tool but trying to install it again makes the tool get stuck at the "installing license server" state.

Any idea how I can get my expensive tool back to work?

Thanks,

Consti

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: reinstalling of Flexnet LM not working for Creo 3


@Consti wrote:

Hi,

Creo 3 licensing became unreliable with windows 10 and now completely stopped working. That means I can not use the software anymore. My reseller suggested me to reinstall the flexnet. The deinstalling went fine using the config tool but trying to install it again makes the tool get stuck at the "installing license server" state.

Any idea how I can get my expensive tool back to work?

Thanks,

Consti


Hi,

my suggestion ... install the latest FLEXnet using standalone installer. You can download it using http://download.ptc.com/download2/products/FLEXnet/flexnetadmin64_11.16.2.1.zip  link


Martin Hanák

View solution in original post

10 REPLIES 10
Highlighted

Re: reinstalling of Flexnet LM not working for Creo 3

My guess is that when uninstalling Flexnet, Windows service has not been removed and now installer tries to update existing installation instead of performing a new one, because it "sees" the service in the registry.

Try to delete Flexnet service (usually lmadmin_ptc) and restart installer, usually it helped.

To delete lmadmin_ptc service, you can run command prompt as an administrator and use command

sc delete lmadmin_ptc

Of course, first check if the Flexnet service exists and if that's the correct name.

Highlighted

Re: reinstalling of Flexnet LM not working for Creo 3

Just another comment ...

I cannot guess what FLEXnet version is available on your Creo 3.0 installation media. It could be 10.8. If this is true, then the service is called FLEXlm server for PTC.


Martin Hanák
Highlighted

Re: reinstalling of Flexnet LM not working for Creo 3


@Consti wrote:

Hi,

Creo 3 licensing became unreliable with windows 10 and now completely stopped working. That means I can not use the software anymore. My reseller suggested me to reinstall the flexnet. The deinstalling went fine using the config tool but trying to install it again makes the tool get stuck at the "installing license server" state.

Any idea how I can get my expensive tool back to work?

Thanks,

Consti


Hi,

my suggestion ... install the latest FLEXnet using standalone installer. You can download it using http://download.ptc.com/download2/products/FLEXnet/flexnetadmin64_11.16.2.1.zip  link


Martin Hanák

View solution in original post

Highlighted

Re: reinstalling of Flexnet LM not working for Creo 3

... and do not forget to install MS Visual C++ 2013 Redistributable Package (both 32-bit and 64-bit).

You can download it using https://support.microsoft.com/en-us/help/4032938/update-for-visual-c-2013-redistributable-package link.


Martin Hanák
Highlighted

Re: reinstalling of Flexnet LM not working for Creo 3

Great,

thanks for the link - the installing worked well (see pictures).

However unfortunately Creo would not launch, not even throwing an error message. I'm stuck..

Highlighted

Re: reinstalling of Flexnet LM not working for Creo 3


@Consti wrote:

Great,

thanks for the link - the installing worked well (see pictures).

However unfortunately Creo would not launch, not even throwing an error message. I'm stuck..


Hi,

run ptcstatus.bat from FLEXnet installation and from Creo 3.0 installation. What are the results ?


Martin Hanák
Highlighted

Re: reinstalling of Flexnet LM not working for Creo 3

ptcstatus.bat

Flexnet:

Displaying status for license file: C:\Program Files\PTC\FLEXnet Admin License Server\bin\..\licensing\license.dat
License Server is UP: C:\Program Files\PTC\FLEXnet Admin License Server\bin\..\licensing\license.dat
ptc_d FLEXnet Publisher version: 11.16
License In Use Free
------- ------ ----
PROE_EssentialsI 0 1

* = License Extensions - Available only on startup.
^ = Borrowed License.

 

 

Creo:

Displaying status for license file: 7788@constantin-pc
License Server is UP: 7788@constantin-pc
ptc_d FLEXnet Publisher version: 11.16
License In Use Free
------- ------ ----
PROE_EssentialsI 0 1

* = License Extensions - Available only on startup.
^ = Borrowed License.

 

Looks good to me. Your link unfortunately is not working for me

Highlighted

Re: reinstalling of Flexnet LM not working for Creo 3


@Consti wrote:

 

Looks good to me. Your link unfortunately is not working for me


Hi,

what happens when you click the link ?

The link will work if you have customer account created at PTC.


Martin Hanák
Highlighted

Re: reinstalling of Flexnet LM not working for Creo 3


@Consti wrote:

Great,

thanks for the link - the installing worked well (see pictures).

However unfortunately Creo would not launch, not even throwing an error message. I'm stuck..


Hi,

look into https://support.ptc.com/appserver/cs/view/solution.jsp?source=Sitecore Article Viewer&art_lang=en&n=... document.


Martin Hanák
Highlighted

Re: reinstalling of Flexnet LM not working for Creo 3

Well that solved it!!

Thank you very much for your help.

Even though there is an error message when opening the help link the page was eventually loading 🙂

Announcements