cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can Bookmark boards, posts or articles that you'd like to access again easily! X

updating license file?

ptc-422934
1-Newbie

updating license file?

I am attempting to update my license file. I have received the new licenses from PTC but when I try to run the ptcsetup.bat file in the flexlm bin diectory in just hangs up on me. The horizontal blue line stops at about half way across and thats as far as it goes.

Any ideas on how to progress anyone?

thanks

Dave

9 REPLIES 9
Dale_Rosema
23-Emerald III
(To:ptc-422934)

Whenever I am updating license files, I usually have a PTC rep or my reseller on the phone to walk me through all the idiosyncrasies.

+1 to what Dale recommended.

If you are going through the setup (install) disks anyway, you might be able to just drag the new file into the license section of the setup. This is probably the most reliable way.

I know I have walked through this a couple times with support using the LM executable. Is this where you are hanging up?

I have now managed to run the programme successfully from the ProE bin directory rather than the flexlm directory.

However, when I got to the part where you have to type in your host_id in it would not configure and told me my host_id was incorrect. I ran the cpu_id programme to check it and low and behold my host_id has changed.

Further investigations suggest that the new wireless card I have fitted has caused this, maybe?

So now I have asked license support how I can get a new license with the new host_id in the text file.

Currently awaiting a reply but if the licence as emailed to me is just a text file I'm assuming I could just edit the text file accordingly. Am I correct?

Ouch.. yes, the Host_ID executable makes this error often. I ran it and it found my router rather than my computer.

If you already have the new license file, drag and drop it in the license file option if it is there.

Now the question is, when you requested the license, which CPU_ID is it tied to

Get customer support on the horn. That will be the fastest way to get this resolved.

Yes, the new license has the old host id in it. However, I have just disabled the new wireless card and enabled the original ethernet adaptor and now my original host id is back!

ProE will still not run though so tomorrow I'm going to re configure the new new license file. It's bed time here in the UK now.

When you say drag and drop the new license file do you mean the text file as emailed to me which is lm_xxxx.txt. To get that option I have to select the third option 'fixed node license' which gives me a browse folder to search for the file location? The first option is a fixed license server which requires a host_id to be typed in I think and the second option is for triads which does not apply obviously. Its been so long since I did this I cant remember if that is correct.

Hope things work better in the morning. It really is a tough thing to get all this license stuff working.

If I hear you right, yes, the LM_xxx.txt file can be dropped in the 3rd entry. Mine is not a Node Locked license but that is where I dropped the file when I just upgraded Creo 2.0 to M030 (don't ask... I had to uninstall the default LM). It goes off and installs the LM server before I could go on with the install. It takes a few seconds. As for the "1st entry", not seeing your screen, I think that goes to the PTC web site and creates a license on the fly based on your account. That never worked for me.

After many issues with the Creo 2.0 flexnet, I decided to replace it by the flexnet installer 10.8.6 (stable release) :

Version 32 bit

Version 64 bit

Before you decide to proceed it, follow the steps :

1. Verify the Host-iD flexnet received from your computer.

In computers now you have different host-iD from different network cards. Only the Host-iD indicated from the PTC license file is the correct one and must be identified by flexnet.

if you don't know how to do ask and We will help you

2. de-install the Creo 2.0 flexnet ( from your windows de-installation tool)

3. install the flexnet 10.8.6 from the right link above

I think that is what PTC CS put on mine.

It reads: PTC License Server Release Wildfire 3.0 Datecode M120 in my Control Panel.

I was told this was the most stable version for single license seats.

You also need to make sure that your physical network card (the appropriate CPU_ID) is the 1st one listed in your Registry. The registry folder needs to be "1" and no other network card folder in the registry should start with "1..." (like "13" is bad).

Thanks everyone. Been a bit sick for a few days but I got back onto the problem today.

Installed the newer version of flexlm and reconfigured it and the ProE. Now everything is fine.

Dave

Top Tags