cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Advanced Grid not rendering last column on Twx 8.5.3

SOLVED
Ecko665
Contributor

Advanced Grid not rendering last column on Twx 8.5.3

Hello, I have an issue with an advanced grid (V4.2.1) where it does not render my last column.  It is fed by a service with output type <Infotable> but no datashape defined. The service executes fine and I can see all the columns in composer.

As well, I have a configuration service output <string>, result fed to the configuration binding of this widget.

Everything was working well with V4.0.1 but it is deprecated and I cannot get it to render properly with the new version.  

I am using TWX 8.5.3, attached pic for reference.

Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Advanced Grid not rendering last column on Twx 8.5.3

According to my tests, if you remove the Grid Advanced Extension from ThingWorx 8.5.3, your existing Grid Advanced widget will stay unchanged, however from then on the Grid Advanced that you will be able to select under the "Widgets" menu will be the out-of-the-box one. 

 

If you have a development or test environment I would suggest that you test there first to see if the out-of-the-box Advanced Grid also misses one column when displaying the same data.

View solution in original post

8 REPLIES 8

Re: Advanced Grid not rendering last column on Twx 8.5.3

Hi @Ecko665,

 

If you are using ThingWorx 8.5.3 you should be able to use the out-of-the-box Advanced Grid widget instead of the one from the Grid Advanced Extension 4.2.1, this is what we would recommend. Are you seeing the same issue with the out-of-the-box Advanced Grid ?

 

In the String output from your configuration service, is this column explicitly stated and shown ?

 

If you added the column later try a refresh on the data source in the Composer and then rebind the data to the Grid.

Re: Advanced Grid not rendering last column on Twx 8.5.3

Hello, thank you for the update.

 

The output of the configuration service is attached, it does not call out or hard code the data in the last row.  It is dynamic based on the entity count per plant.

 

I've attached a picture showing what I have available for the grid widget, and I cannot pick the legacy advanced grid.

By removing the AG 4.2.0 extension, would the out of the box replace it?

 

Thanks again,

 

Please let me know as this is on a Prd server and I 

Re: Advanced Grid not rendering last column on Twx 8.5.3

According to my tests, if you remove the Grid Advanced Extension from ThingWorx 8.5.3, your existing Grid Advanced widget will stay unchanged, however from then on the Grid Advanced that you will be able to select under the "Widgets" menu will be the out-of-the-box one. 

 

If you have a development or test environment I would suggest that you test there first to see if the out-of-the-box Advanced Grid also misses one column when displaying the same data.

View solution in original post

Re: Advanced Grid not rendering last column on Twx 8.5.3

Great, thanks for the feedback.  I will further test this within my Dev platform.

One thing I noticed, is that I have no style themes with my current advanced grid widget(4.2) outside of cellValidationErrorStyle and cellValidationErrorToolTipStyle.

 

I tried Article CS329247 however I do not have the UseTheme check box available?  Any ideas.

 

Thanks again,

Re: Advanced Grid not rendering last column on Twx 8.5.3

Sure !

 

According to your description, I believe the issue with the missing Styles you are seeing might rather come from the Advanced Grid Extension rather than the UseTheme option. 

See Styles from Grid Advanced widget Style Properties are not shown in ThingWorx 8.5 after upgrading fro....

Re: Advanced Grid not rendering last column on Twx 8.5.3

Thanks for the feedback.

 

My case is different as I upgraded to 8.4 -> 8.5 some time ago and was using the out of the box Advanced Grid Widget V 4.0.1 until importing V4.2.0.  At this moment, I noticed the styles were missing. This topic can be closed.

 

Regarding Widget deprecation, are widgets deprecated after upgrading TWX to a newer version, or do they deprecate on their own?

 

Thanks again,

Re: Advanced Grid not rendering last column on Twx 8.5.3

@Ecko665,

 

Thanks for your feedback !

 

If you are asking in what context the legacy widgets are ultimately being removed from the Platform, indeed this happens after upgrading to a later version.

Re: Advanced Grid not rendering last column on Twx 8.5.3

Hi @Ecko665.

 

If you feel your question has been answered, please mark the appropriate response as the Accepted Solution for the benefit of others with the same question.

 

Regards.

 

--Sharon

Announcements

Check out the upcoming Expert Session: Understanding ThingWorx Navigate Licensing in Community "Customer Events" section.