cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creating a Mashup Widget Extension jdk required version

nahuel
13-Aquamarine

Creating a Mashup Widget Extension jdk required version

Hi!

 

I'm trying to validate the flow of Creating a Mashup Widget Extension.
This guide is useful but the requirements are outdated.

nahuel_0-1625517308149.png

What jdk version is requiered for building an extension for ThingWorx 9.x?
And for linux, if open jdk is supported, which version is required also for TWX 9.x?

 

In the step 1 of the same guide there are two links, one to the Eclipse Plugin and one to the Extension SDK.
Looking at the URL I found it says "trialeditions". What are the diferrences between the non-trialedition and the trialedition?

 

Regards

1 ACCEPTED SOLUTION

Accepted Solutions
BogdanM
5-Regular Member
(To:nahuel)

For widget extensions you don't need any kind of jdk as these are developed using javascript and css. You also don't have to use eclipse or the Thingworx plugin and can instead use any IDE with good javascript support (such as visual studio code).

 

Widgets that aren't based on the visual sdk don't have any dependencies for Thingworx and you can just write and compress the javascript files by hand to get started.

 

If you want to build on top of the visual sdk, you can follow the getting started guide at http://support.ptc.com/help/thingworx_hc/visual_sdk/

View solution in original post

2 REPLIES 2
BogdanM
5-Regular Member
(To:nahuel)

For widget extensions you don't need any kind of jdk as these are developed using javascript and css. You also don't have to use eclipse or the Thingworx plugin and can instead use any IDE with good javascript support (such as visual studio code).

 

Widgets that aren't based on the visual sdk don't have any dependencies for Thingworx and you can just write and compress the javascript files by hand to get started.

 

If you want to build on top of the visual sdk, you can follow the getting started guide at http://support.ptc.com/help/thingworx_hc/visual_sdk/

View solution in original post

slangley
23-Emerald I
(To:nahuel)

Hi @nahuel.

 

If you feel your question has been answered, please mark the previous response as the Accepted Solution for the benefit of others with the same question.

 

Regards.

 

--Sharon

Announcements