cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

D3 Tree and Network widgets issue

Highlighted
Marble

D3 Tree and Network widgets issue

Hi Guys,

I have some issues with D3 widgets for Network and Tree.

No matter what I do, I cant just see anything after my Mashups loaded. Original Tree widget works just fine.

I made a simple network with one root element and 10 nodes.

I am running TW 7.1.0

There is no video tutorial or any other document for new D3 widgets, as far as I can tell.

Can somebody provide me with some screenshots how the widgets need to be setted up.

Thanks.

Tomas

7 REPLIES 7

Re: D3 Tree and Network widgets issue

Just tested this and both D3 work fine

Make sure you have Labelfield, To and From properly assigned.

to verify, you can split your layout and place a regular Tree widget next to it and wire it up the same way to verify.

Re: D3 Tree and Network widgets issue

Hi Tomas,

I too tested D3 tree and it worked fine on my ThingWorx 7.2.1 Instance.

Can you share the exact steps you are following and I can try the same on my Instance.

Basically we need to follow the same steps shared for original Tree widget and it should work.

Thanks,

Ankit Gupta

Re: D3 Tree and Network widgets issue

Hi Ankit,

here are the screenshots. It should pretty self explanatory.

Re: D3 Tree and Network widgets issue

Hi Tomas,

Everything seems fine. Same steps works on my instance.

Screenshot from my instance.

Any error in logs?

Thanks,

Ankit Gupta

Re: D3 Tree and Network widgets issue

No errors, none in the console, nor in Application logs.

Any other suggestion?

Should I restart the Tomcat after D3 extensions were added? Should I remove them and add them again??

T.

Re: D3 Tree and Network widgets issue

You probably already tried CRTL + F5 for a full browser/widget reload right?

Re: D3 Tree and Network widgets issue

Yep,

deleting the extensions and putting them back on helped...

Thanks