cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Directory Service using LDAPS fails to connect

Directory Service using LDAPS fails to connect

Hello,

I need to integrate ThingWorx security with our Active Directory. I managed to connect to it using LDAP over port 389, tested it running the "GetDomainGroups" service and it returns all the groups in the defined branch from AD.

When I change the protocol to use LDAPS over port 636, and try to run the same service, I get an error: "Unable to Invoke Service GetDomainGroups on LDAPS : simple bind failed: servername:636".

I have a SSL certificate from my company (.pfx format) that I configured in Tomcat, so its running on https (i just copied the file into tomcat folder and configured the server.xml file to use it). Not sure if its there is anything else i should have done.

Thanks,

Konrad

Tags (2)
4 REPLIES 4

Re: Directory Service using LDAPS fails to connect

Hello, Konrad.

First question; what version of ThingWorx are you running? 7.1.1 or later is needed for LDAPS support. Did it connect correctly on standard LDAP previously?

You followed the procedure of this article?

https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS221840

-- Craig A.

Re: Directory Service using LDAPS fails to connect

Hi Craig,

I am using version 7.4, should be fine.

And it works fine for LDAP. I have 2 entities on my directory services, one for LDAP and one for LDAPS, and like I said, the only difference is the port number.

I did read that article, but it doesnt explain about the LDAPS piece.

Thanks,

Konrad

Re: Directory Service using LDAPS fails to connect

Any suggestions?

Re: Directory Service using LDAPS fails to connect

Can you please check the following?

The article covers LDAPS

Cannot connect to LDAP Server on port 389, 3268 and 636. | Knowledge Base | SonicWall