cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

DropDown widget is not displaying needed data

Ike@ACE
Granite

DropDown widget is not displaying needed data

I'm still trying to get the DropDown widget to work properly. This time the problem is that the usernames are not being displayed in the menu of the widget. I think I've got the needed connections in place, I may be missing one, though. I'm not sure. If I use the "View Mashup" button, I get an error like this:

 

Failed to load resource: the server responded with a status of 500 ()

 

that points to the GetUsersofAdmin service. As I'm  sure you are aware this usually points to a missing permission somewhere, but I can't find it. I've double checked all of the needed permissions that I can think of. The weird thing is that if I use a private window to log into the correct FormLogin to check the errors that come up when I log in with a specific user, I don't get any errors. It seems to be working properly, but the DropDown menu doesn't show any data. I've attached a picture of the connections. Thanks in advance.

2 REPLIES 2

Re: DropDown widget is not displaying needed data

In this case, you should check the infotable result is stable first, so you can use Grid widget instead of Drop down widget to access the data.  If the Grid doesn't show any thign, surely the dropdown won't receive anything.

 

And then , you can check whehter your data source service is reliable. 

Re: DropDown widget is not displaying needed data

So, it is definitely a problem with the infotable results not being stable. However, I've successfully executed the code while writing it multiple times. There's got to be a permission I'm missing. I'm attaching a screenshot of my code and the results from execution. I'm not sure what I'm missing.

Announcements

Check out the upcoming Expert Session: Understanding ThingWorx Navigate Licensing in Community "Customer Events" section.