cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Error importing entities from Thingworx7.3 to 7.4

SOLVED
Highlighted
Newbie

Error importing entities from Thingworx7.3 to 7.4

When importing entities exported from Thingworx 7.3 (both Binary and XML) i get the error, 'Error Importing, Not Acceptable'

Any idea why this is or how to get around it? It would be a real problem to recreate what I've already done from scratch.

The versions I am using are:

Thingworx 7.3 PostgreSQL

Thingworx 7.4 MSSQL

As always, any help appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Error importing entities from Thingworx7.3 to 7.4

Solved this now, It appears the import error messages in the composer are wrong?

When looking at the application log it clearly told me i was missing an extension.

Installed extension, Import Successful.

Thanks for your help anyway!

View solution in original post

10 REPLIES 10
Highlighted

Re: Error importing entities from Thingworx7.3 to 7.4

Matthew, what sort of entities are these? how were they exported and what options are you selecting when importing them in v7.4?

Highlighted

Re: Error importing entities from Thingworx7.3 to 7.4

I'm using the Export to File option and only filtering it by Model Tag, This then consists of a variiaty of entities such as mashups, things, thing shapes, thing templates, organisations, value streams, media & so on. I have tried exporting as both Binary and XML.

This method worked for me well when using 7.1, 7.2 & 7.3 and worked easily between them all.

When importing i am selecting Import from File, entities, Use default persistence provide (have tried this also unchecked) & ignore subsystems are all checked. Then selected the file exported from 7.3 and it fails to import.

Highlighted

Re: Error importing entities from Thingworx7.3 to 7.4

Did you get this error on your first import attempt? Could you also attach/copy&paste the application log

Highlighted

Re: Error importing entities from Thingworx7.3 to 7.4

Solved this now, It appears the import error messages in the composer are wrong?

When looking at the application log it clearly told me i was missing an extension.

Installed extension, Import Successful.

Thanks for your help anyway!

View solution in original post

Highlighted

Re: Error importing entities from Thingworx7.3 to 7.4

It indeed was misleading and tricky to judge from that message alone, thus it's usually helpful to check the application log (i usually increase the logging to trace, at least for the the time i'm debugging, to get more info logged when getting such cryptic messages). By the way which extension was it which you had to import?

Glad it worked out!

Highlighted

Re: Error importing entities from Thingworx7.3 to 7.4

Sorry for the delayed reply, it was the iMonnit extension!

Highlighted

Re: Error importing entities from Thingworx7.3 to 7.4

Hi,

Im having the same issue. I'm trying to install navigate and when i try to import the sample mashup i get that error.

The application log file says the following.

2017-04-26 14:50:19.230+1000 [L: ERROR] [O: c.t.c.ImportProcessor] [I: ] [U: Administrator] [S: ] [T: http-apr-8081-exec-19] Unable to process import: Thing ptc-windchill-demo-thing has an invalid thing template [WindchillConnector]

2017-04-26 14:50:19.230+1000 [L: ERROR] [O: c.t.w.Importer] [I: ] [U: Administrator] [S: ] [T: http-apr-8081-exec-19] Entity import failed

2017-04-26 14:50:19.230+1000 [L: ERROR] [O: E.c.t.w.Importer] [I: ] [U: Administrator] [S: ] [T: http-apr-8081-exec-19] [message: Import Failed: Thing ptc-windchill-demo-thing has an invalid thing template [WindchillConnector]]

2017-04-26 14:50:19.230+1000 [L: ERROR] [O: c.t.w.Importer] [I: ] [U: Administrator] [S: ] [T: http-apr-8081-exec-19] Internal error: java.lang.Exception: Import Failed: Thing ptc-windchill-demo-thing has an invalid thing template [WindchillConnector]

201

Highlighted

Re: Error importing entities from Thingworx7.3 to 7.4

Bryan Kirchner​,

It seems that thing template [WindchillConnector] is missing in your system which indicates that ptc-windchill-connection-extension is not imported.

Please import ptc-windchill-connection-extension to resolve this issue.

I hope it helps.

Highlighted

Re: Error importing entities from Thingworx7.3 to 7.4

That helped, and I can now import the sample mashup. (thanks)

I suppose that the process will be the same for the main export that I did?

As my "AllEntities.twx" gives me the same issue.

step one: import "AllEntities.twx"

step two: read application log.

Step three: find and import extension

Step four:  return to step one.

Highlighted

Re: Error importing entities from Thingworx7.3 to 7.4

Hi Bryan Kirchner​,

Application logs will actually point us to the entities which are missing while importing. These entities could be part of some Extension. But it does not tell about the extension name.

As a best practice; we should make a note of name/details of all extensions while taking the export from a system and import them in following order:

1. Import all the extensions noted.

2. import the entities.

3. import the data.

I hope it helps.

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!