cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about PTC Community Badges. Engage with PTC and see how many you can earn! X

Error shown "Connection to server could not be established" during ThingWorx installation

AP_9587236
17-Peridot

Error shown "Connection to server could not be established" during ThingWorx installation

MSSql Database is installed and configured. Now not able to proceed furthur while installing ThingWorx-Foundation-Installer-mssql-windows-9-2-8. What is the issue here ? I referred this article also support.ptc.com/help/thingworx/platform/r9/en/index.html#page/ThingWorx/Help/Composer/DataStorage/PersistenceProviders/mssql_database_setup_for_thingworx_windows.html

 

 

AP_9587236_1-1658269215046.png

 

3 REPLIES 3

@AP_9587236 ,

 

Have you tried connecting to that database from another client on your ThingWorx server, such as SQL Management Studio?  You may need to enable ports or remote connections on your SQL server.

 

Nick

1433  and 1434 ports enabled for mssql and mssql express. Now SQL server agent is not running. Is this might be a reason for not able to install Thingworx foundation ?

AP_9587236_1-1658325786136.png

 

slangley
23-Emerald II
(To:AP_9587236)

Hi @AP_9587236 

SQL Server agent isn't needed for running ThingWorx. It's used for executing scheduled jobs at the database level--outside of ThingWorx.  You can google for a number of posts for resolving issues with SQL Server agent.

In regard to your installation failure, here are some things to check:

  • Did you install sqlcmd on the ThingWorx machine (if running on a separate machine from the database)?
  • Are you able to connect to the db through SQL Server Mgmt Studio? 
  • Is SQL Server installed on the same machine as ThingWorx or a different machine?  If on a different machine, run this command to confirm the SQL Server port is accessible over your network:  telnet 10.185.202.203 1433
    If it returns a blank window, the connection was successful.  If not, you need to confirm the server firewall on the SQL Server machine is allowing access to 1433
  • Have you run the SQL Server Configuration Manager to ensure that TCP/IP is enabled? In the Configuration Manager:
    1) Select SQL Server Network Configuration >  Protocols for SQLEXPRESS
    2) In the right pane, verify that TCP/IP is enabled.  If not, right-click and select Enable
    3) Right-click TCP/IP and select Properties
    4) Select the IP Addresses tab, and enable the appropriate ones
    5) Restart SQL Server if changes were made
  • When you installed SQL Server, did you select mixed mode?  In SQL Server Mgmt Studio:
    1) Right-click the name of the server
    2) Select Properties
    3) Select Security
    4) Validate that "SQL Server and Windows Authentication Mode" is selected.  If you have to change the setting, it will be necessary to restart SQL Server.

Regards.

--Sharon

Top Tags