Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Failed to load FlxCore Library


Failed to load FlxCore Library

I'm having an issue with starting up a Thingworx composer with Tomcat and the only error i'm getting in the Thingworx application log is:

[L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Failed to load FlxCore library. Ensure it's in PATH (Windows) or LD_LIBRARY_PATH(other platforms) or set with the VM arg, -Djava.library.path. Error message : com.flexnet.licensing.DllEntryPoint.entry([B)I

First off, a couple of points to note.  The machine i'm working on at the moment hasn't been used in about 3 months, but it previously had an instance of Thingworx running on it previously with no issues at all.  It was primarily used for testing things in a dev environment and hasn't been touched or updated in that time.  Also I've double checked the PATH and added both the "<tomcat>/webapps/Thingworx/WEB-INF/extensions" directory and the same but with the FlxCore64.dll on the end and neither of these solve the issue.

A lot of other discussions i see on here list that the issue might lie with Java.  the Java version on the machine is 1.8 64bit :

java version "1.8.0_141"

Java(TM) SE Runtime Environment (build 1.8.0_141-b15)

Java HotSpot(TM) 64-Bit Server VM (build 25.141-b15, mixed mode)

Now since nobody has used this machine in several months, and Thingworx worked just fine on here before, i doubt there's anything wrong with any configuration.   I currently suspect it might be an issue with the license.bin file after reading several support articles:

7.4 ThingWorx does not launch due to license error in Windows

However, none of the solutions presented by these articles have worked.  Is it actually an issue with the license? Is there any way i can check? could there be something else I have not noticed in one of the logs?

Any help would be appreciated,

Many thanks,



hi, i have the same error, but on linux machines.

You can try the solution, wich worked for me, from the official installation document:

NOTE: If you get an error, create a new file in the tomcat /bin file named

CATALINA_OPTS="$CATALINA_OPTS -Djava.library.path=/usr/share/tomcat8.5/8.5.23/webapps/Thingworx/WEB-INF/extensions"

In your case you probably need to create a setenv.bat with the following content (Attention syntax could be different on windows (don't know windows commandline very well!)):

set CATALINA_OPTS="%CATALINA_OPTS% -Djava.library.path=/usr/share/tomcat8.5/8.5.23/webapps/Thingworx/WEB-INF/extensions"

replace the part "/usr/share/tomcat8.5/8.5.23/" with the path to your Tomcat installation (e.g. C:\Tomcat.....)