cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

How to avoid that hovering the mouse on grid rows changes the style of the row?

SOLVED
GP_9630672
Participant

How to avoid that hovering the mouse on grid rows changes the style of the row?

When a line is hovered in a Grid widget, the style that is set in the "RowFormat" property is ignored and a different style is applied.
The one that is used is set in the "Style Properties" tab of the widget and, on all of them, by default, is the Style Definition: DefaultRowHoverStyle.
 
This causes weird behaviours because of the different font size between both styles.
 
I do not know if it is possible but I think that the best solution would be to disable the style modification for hovering lines in grids. I could not find a way to do it, but maybe you know a way to do so.
 
In case you wonder, I am using ThingWorx 8.5.8-b414
 
Thanks for your help!
1 ACCEPTED SOLUTION

Accepted Solutions

Re: How to avoid that hovering the mouse on grid rows changes the style of the row?

Hello @GP_9630672 ,

 

Have you tried to remove the RowHoverStyle (Style Properties) and select a different Style or create a New Custom Style ?

 

Hope it helps,

View solution in original post

2 REPLIES 2

Re: How to avoid that hovering the mouse on grid rows changes the style of the row?

Hello @GP_9630672 ,

 

Have you tried to remove the RowHoverStyle (Style Properties) and select a different Style or create a New Custom Style ?

 

Hope it helps,

View solution in original post

Re: How to avoid that hovering the mouse on grid rows changes the style of the row?

I was looking for a way to modify all the grids but yeah, it works. I just have to modify tens of them...

Thanks!

Announcements

Check out the upcoming Expert Session: Understanding ThingWorx Navigate Licensing in Community "Customer Events" section.