cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Installing Thingworx 7.1 - Could not authenticate Invalid authentication content

mpagliotta
1-Newbie

Installing Thingworx 7.1 - Could not authenticate Invalid authentication content

Hello,

I tried to install Thingoworx 7.1 with Java 8.1  Apache Tomcat 8.0 and PostgreSQL 9.5 (PgAdmin III) in Windows Server 2008 R2 Enterprise Service Pack 1.

I followed the steps on the manual:

1) install Tomcat and run the service

2) install PostgreSQL with PgAdmin III and create the login role

3) Create ThingworxPostgresqlStorace in C with full control to NETWORK SERVICE

3) Try to run the Bat files (Setup and Schema) after configured that  (i created the thingoworx DB and tablespace via PgAdmin GUI )

below the code:

-- Tablespace: thingworx

-- DROP TABLESPACE thingworx

CREATE TABLESPACE thingworx

  OWNER twadmin

  LOCATION 'C:\\ThingworxPostgresqlStorage';

-- Database: thingworx

-- DROP DATABASE thingworx;

CREATE DATABASE thingworx

  WITH OWNER = twadmin

       ENCODING = 'UTF8'

       TABLESPACE = thingworx

       LC_COLLATE = 'English_United States.1252'

       LC_CTYPE = 'English_United States.1252'

       CONNECTION LIMIT = -1;

Schermata 2016-05-10 alle 12.06.32.png

4) Create the json file in the Thingworx Platform folder in C: (attached file)

5) Added the thingworx.war file in webapps folder

in "manager apps"  it seems ok:

Schermata 2016-05-10 alle 02.27.58.png

when i click on Thingoworx something went wrong:  Could not Authenticate, Invalid Authentication content

Schermata 2016-05-10 alle 08.36.16.png

I tried to start and stop the app and reload with no results.

What's went wrong?

Anyone can help me?

Thanks

15 REPLIES 15

Marco, the password set for twadmin and the one in the platform-settings.json matches, correct? Also, we support (and recommend) PostgreSQL 9.4. Please do install that instead. On a side note, similar to the other thread, please do post your Application log from ThingworxStorage/logs and Catalina logs from Tomcat_install_path/logs folder.

i remove PostrgreSQL 9.5 and install 9.4. I tell you if it's work. Thanks

i'm stucked at this point, during configuration of PostgreSQL 9.4

Schermata 2016-05-11 alle 00.16.13.png

Can i create tablespace and database using GUI Pg admin instead of bat file?

I need to delete the following stuff because impact on Postgresql?

Schermata 2016-05-11 alle 00.18.50.png

(all in C: path)

Thanks

Inside the bat file:

Schermata 2016-05-11 alle 00.20.54.png

Marco, you can create them in the pgAdmin tool as well. A tablespace exists, correct? You can right click Databases and add a new Database called 'thingworx' with the owner set to twadmin. If you don't have a tablespace, you can add that one too, a tablespace called 'thingworx'. Make sure the Location field in Definition points to '\ThingworxPostgresqlStorage'.

Marco, the user trying to execute the bat file might have no access permissions to the .sql files. Try adding full-control permissions to the user and execute the script. Also, try executing the bat file as 'Administrator'.

Where did you all find the .bat file? I'm stuck at this step.

Yuri, did you download the package from the Support portal? The zip file should have all the files required for installation.

No, I downloaded the trial edition.

And I just found out I just need to change my Java version in order to play with Thingworkx trial edition.

Thanks for your answer

Hello,

is this issue solved? I  have run in the same situation and no idea what can be the solution of it.

Thanks.

Miklos, can you post your logs? Can you try the steps/ suggestions mentioned in this thread as well?

Hi Aanjan,

i  followed already these steps, the only difference is that (maybe is important) i have Windows 10. Please see my logs.

Thanks for your help.

supandey
19-Tanzanite
(To:mlorincz-2)

Just wanted to put this out here since I recently installed TW 7.1.3 with PostgreSQL 9.5.3 and I kind of ran into same issue but then i realized it was due to the incorrect settings (was my mistake) in the platform-settings.json file. I tried creating this file completely from scratch using the Appendix B: Sample platform-settings.json from the installation guide of ThingWorx 7.1.1 (page 46) and obviously tried too many settings without completely understanding the implication of each setting.

To resolve the issue I used the sample file that comes with the download package from the PTC Software Download page which has basic settings to get you up and running - all it need is configuration to the server, username & password and the JDBC URL.

May be Miklos Lorincz​ you want to copy this file over as a starting point and once you have a successful connection try to extend the settings using the Apendix B: Sample platform-settings.json as a reference. Of course, lookout for the other steps and suggestions discussed in this thread.

Hope this helps.

Hi again,

after i tried to install on another System i realized that there was some system issue.

I made a clean up with thingworxPostgresDBCleanup.bat i re-runn the thingworxPostgresDBSetup.bat, i need to re-create the thingworks table space manualy, i did the following setup:

- i set the password for twadmin again

- re-set the location of the Storage

- i set the owner of the table space as twadmin

- run the thingworxPostgresSchemaSetup again

and that was it. Everything works now on my system to.

Maybe something hasn't run at the begging with the setup batch but after i made a clean and remade almost everything .

Thank you all for your help.solution.png

Miklos, just so I understand, removing everything and starting from scratch and re-running the script files worked?

Announcements