cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Legend Color and Line Color are not matching the LineChart

Shashi_Preetham
16-Pearl

Legend Color and Line Color are not matching the LineChart

As shown below, Tank-108 is selected, which has the Legend color Blue, but as per the LineChart, it is showing Pink.

Shashi_Preetham_1-1658415169836.png

As you saw below Screenshot, the Legends colors are duplicated if the NumberOfSeries Property in the LineChart Widget is set to Auto

Shashi_Preetham_3-1658415520621.png


Thingworx Version: 9.3.2

Thanks,
Shashi.

 

Shashi Preetham (psp316r)
1 ACCEPTED SOLUTION

Accepted Solutions

@PEHOWE ,

You are right to a certain point, instead of removing the Specification color in the data  provided, we removed the default color assigned to the Series in the Style Properties of the Chart, that solved the issue. Due to Default color assigned to chart, there was a duplicity in the colors.

Thanks,

Shashi Preetham (psp316r)

View solution in original post

6 REPLIES 6

Hello @Shashi_Preetham,
 

Have you reviewed Article - CS341203 - Data line rendered in Line Chart widget doesn’t match the color of its correspo...

The description seems to be on point with the issue you describe.

 

Let me know what you find.

 

 

Hi @PEHOWE ,

The issue is similar, but as per the Article, that was corrected 9.2, but isn't should be corrected in 9.3.2(Which my team is using) ?

Thanks,
Shashi.

Shashi Preetham (psp316r)

@Shashi_Preetham,

Are you trying to specify the color?  If you are specifying the color with your configuration, I will need to retest the issue. 

Thanks

Peter

@PEHOWE ,

Yes, trying to specify color, if the legend shows one color and in the Chart the line of another color, that will cause much confusion to the user/client.

Thanks,
Shashi.

Shashi Preetham (psp316r)

@Shashi_Preetham

 

If you remove all the color specification from the data being provided to the chart. Does the chart draw with a single color for each item?
I will see if I can get a test case and review the issue.

@PEHOWE ,

You are right to a certain point, instead of removing the Specification color in the data  provided, we removed the default color assigned to the Series in the Style Properties of the Chart, that solved the issue. Due to Default color assigned to chart, there was a duplicity in the colors.

Thanks,

Shashi Preetham (psp316r)
Announcements